Zidoo X8 vs X9S vs X10 (vs Zappiti Mini 4K HDR)

adam-burnley

Distinguished Member
OK mate so thanks to you and the timely answers I'm there - appreciate it. V2.0 is growing on me as it seems it's my bone idleness in not naming the files inside the files correctly that's stopping the scraper. However, 4 more scans got me down to 4 rogue files which I sorted by naming the video files corectly -ie taking off the t00 or removing the _ from between the words...just one more thing before I let you live in peace...how do you turn the confounded subtittles off for good? :rolleyes:
Yeah I know what you mean about the file names - purely luck on my part (and mild OCD), but I decided very early on to rename the rips and remove the _ and .t0x extensions. Although I have created problems for myself by adding 3D or Atmos to the file name, which has caused problems with the scraper.

As for subs, well I've always ripped with only Forced English subs selected, so have never had the issue, but I believe you can turn them off permanently by going in to the Advanced menu during playback, and scrolling down for the Subs option and turning it off there. If you turn them off in the Subs menu that is at the top of the first menu, it's just for that playback session - so go in to the Advanced menu. Let us know if that works or not.
 

DracUK

Active Member
Free delivery to members?

That drive is on the supported list, but is slower than the one at £60 (BW-16D1HT). For reference, ebuyer have that BC-12D2HT drive for £50.45 inc delivery as well.

Scan has free next day delivery for AVF menbers spending £50 exc VAT (think thats right,I always get free delivery usually spend more anyway)

That drive can be shipped with firmware 3.00,3.01,3.02 or 3.03
firmware 3.01 or 3.02 are ok but 3.03 fixes the uhd "loophole"
Quite a bit of info on the usual place,also reflashing
regards
 

adam-burnley

Distinguished Member
Scan has free next day delivery for AVF menbers spending £50 exc VAT (think thats right,I always get free delivery usually spend more anyway)
I wasn't aware, so good to know! How does that work exactly, how do they know you are an AVF member?

That drive can be shipped with firmware 3.00,3.01,3.02 or 3.03
firmware 3.01 or 3.02 are ok but 3.03 fixes the uhd "loophole"
Quite a bit of info on the usual place,also reflashing
Yes, 3.0.2 is the last good firmware, and pretty fast too :smashin:
 

Nobbler

Distinguished Member
Yeah I know what you mean about the file names - purely luck on my part (and mild OCD), but I decided very early on to rename the rips and remove the _ and .t0x extensions. Although I have created problems for myself by adding 3D or Atmos to the file name, which has caused problems with the scraper.

As for subs, well I've always ripped with only Forced English subs selected, so have never had the issue, but I believe you can turn them off permanently by going in to the Advanced menu during playback, and scrolling down for the Subs option and turning it off there. If you turn them off in the Subs menu that is at the top of the first menu, it's just for that playback session - so go in to the Advanced menu. Let us know if that works or not.
I managed to get them off by doing basically what you suggested - so I'm pretty much sorted now apert from the fact that I'm not 100% sold on the picture quality. It looks OK on my TV but when I use my projector everything looks a few clicks darker - like somebody has turned the brightness down. Can't understand it really. Seems to be sending a correct signal according to the info on the projector so I'm not sure. I thought it might be the video level but I've got that set to standard so that shouldn't change anything. It reminds me of when I had a Pioneer receiver that adjusted everything to full range so was pushing 0-255 instead of 16-255. Didn't last long.
 

adam-burnley

Distinguished Member
I managed to get them off by doing basically what you suggested - so I'm pretty much sorted now apert from the fact that I'm not 100% sold on the picture quality. It looks OK on my TV but when I use my projector everything looks a few clicks darker - like somebody has turned the brightness down. Can't understand it really. Seems to be sending a correct signal according to the info on the projector so I'm not sure. I thought it might be the video level but I've got that set to standard so that shouldn't change anything. It reminds me of when I had a Pioneer receiver that adjusted everything to full range so was pushing 0-255 instead of 16-255. Didn't last long.
I'm sure you will have ruled out the possibility of the avr and / or cable to PJ causing the issue. Any processing enabled on the avr for instance?

Have you got all the Display options set to Auto?

What content are you testing - 1080p 2D / 3D or 4K HDR?
 

Nobbler

Distinguished Member
It's all 1080/24 content mate and all cables are good yes. My AVR only has processing to upscale to 4k which works on the main HDMI out only - the sub is only passed through.

At the beginning of this thread there's some links to another forum where some guys get really angry about this player. The conclusion was NOT to leave everything on auto. One of them went right into it and it baffled me (and I've attended the THX calibration course). I'll reset them all to auto and see how I get on with that. The PJ and receiver both have info buttons that give readouts on what's coming in/going out both audio and video. Got a night in tomorrow to myself so will have a better look then.
 

adam-burnley

Distinguished Member
It's all 1080/24 content mate and all cables are good yes. My AVR only has processing to upscale to 4k which works on the main HDMI out only - the sub is only passed through.

At the beginning of this thread there's some links to another forum where some guys get really angry about this player. The conclusion was NOT to leave everything on auto. One of them went right into it and it baffled me (and I've attended the THX calibration course). I'll reset them all to auto and see how I get on with that. The PJ and receiver both have info buttons that give readouts on what's coming in/going out both audio and video. Got a night in tomorrow to myself so will have a better look then.
Are you referring to mtenga? Coincidentally he has just got an X10 today, and reported excellent PQ! Have a look in the X10 owners thread.

My Sony PJ is boxed up at the moment whilst my room is built, so I can't easily test again. I do have a mixture of 1080p TVs and a 4K HDR TV, and PQ seems excellent to me. I can get some output info on a couple of AVRs I think, plus I have a HD Fury Linker that I could add to the chain and see what's going on. Let me know if you need anything, but be warned, I've no idea when it comes to calibration :blush:
 

Nobbler

Distinguished Member
Are you referring to mtenga? Coincidentally he has just got an X10 today, and reported excellent PQ! Have a look in the X10 owners thread.

My Sony PJ is boxed up at the moment whilst my room is built, so I can't easily test again. I do have a mixture of 1080p TVs and a 4K HDR TV, and PQ seems excellent to me. I can get some output info on a couple of AVRs I think, plus I have a HD Fury Linker that I could add to the chain and see what's going on. Let me know if you need anything, but be warned, I've no idea when it comes to calibration :blush:
No mate it's the link to another forum above
 

Nobbler

Distinguished Member
Sorry messed up the multi quote. It's this link - Feedback - Zidoo X9S,,,Quick Review (FW 1.4.6) - from page 2. The link goes on for ages and you need to read the links within...boils down to the chips are faulty and need to be setup in a certain way as it automatically selects HDMI full range IIRC
 

Nobbler

Distinguished Member
Ok I shall give auto a try on all video settings. I'm hoping I can get it right as I've got over 200 films ripped now and this looks like the best solution. My Blu-ray player has a decent PLEX app but it doesn't stream lossless sound- only core DD and DTS.
 

Nobbler

Distinguished Member
Actually I may have it the wrong way round and the Zidoo is actually better. I've uploaded a couple of phone camera shots. First one is the Zidoo, second one is the PLEX app on my Xbox One S. Note the white crush on the second pic on Desmonds shirt (taken from Hacksaw Ridge of course) - also if you enlarge the pic you'll see stripes on the shirt from the Zidoo but the Xbox has crushed threse out of the picture...
 

Attachments

  • 20180208_185754.jpg
    20180208_185754.jpg
    1.6 MB · Views: 129
  • 20180208_185514.jpg
    20180208_185514.jpg
    1.4 MB · Views: 127

mtenga

Distinguished Member
Sorry misread. I know some were fairly critical in the early days. Numerous updates since have delivered major improvements.
Quite so, it is not the same as it was in Dec 2016. The X9S was hopeless then, the X10 looks very promising now.
 

hamid22

Active Member
hi can anyone tell me if there is any difference in picture Quality between the Zidoo x9s and the zappiti one hdr thanks
 

adam-burnley

Distinguished Member
hi can anyone tell me if there is any difference in picture Quality between the Zidoo x9s and the zappiti one hdr thanks
I didn't see any difference between the Zidoo and the Zappiti Mini HDR when I compared them last year, and the One HDR will be the same as the Mini. There were reports of a firnware update adversely affecting PQ on the Zappiti a while ago, but I think that's been sorted.
 

sharok

Novice Member
Hello,

A couple of questions for you regarding Zidoo X8 / X9S:

In Ziddo X series (I just purchased an X8 since I'll use it with a couple of external USB HDD only, no networking or sharing), if you set the resolution to 1080p/24 under "TV System", what happens to DVD (720p) files?
Will they get upscaled to 1080p or will they just pass through?

My processor cannot pass 4K and I have a LG OLED TV (E6).

What is the best setup for Zidoo X9S (or X8 since they're functionally the same) related to my TV? I'd like to pass 1080p only (upscale 720p to 1080p, is it even possible?)

All the files are ripped using MKV (BD, 3D MKV, DVD). They're either 1080p/24 (BD and 3D) or 720p (DVD).

Many thanks in advance
 

Coruja3D

Active Member
Hi @sharok - I'll check into my settings when I get home. I have the X9S.

I see you are a fellow LG OLED E6 owner! :clap:

I'm curious what you mean by "My processor cannot pass 4K and I have a LG OLED TV (E6)."? You mean of your NAS? Or HTPC? If you are streaming files over the network I don't think this matters - the Zidoo processor does the 'heavy lifting' of decoding. It has happily played 4K files (MKV, ISO and MP4) I've thrown at it this way, including correctly triggering HDR mode on the E6.

With the same TV as you (passing the signal thro my Sony AV) I have the output resolution set to Auto and Resolution + refresh rate switching on also. For Blu-ray 1080p ISO's it outputs 1080p. Same for Blu-ray 1080p MKV rips (both 3D and 2D) I've found so far.

I only have a few DVDs (in ISO format) and it does not play these particularly well initially I've found - the aspect ratio is off and menu navigation can be iffy. However during playback I can force the AR to 'Full' or "16:9" (via the Zidoo player options) and they then look OK to my eyes.

I've not checked whether it's actually upscaling these - but either the Zidoo needs to or the TV does, so does it matter I wonder? IMO theE6 does not do a great job of upscaling non-HD sources (I watch very little of these anyway), but DVD's played via the Zidoo are watchable for me (if I scoot my chair back a bit!)
 

sharok

Novice Member
Hi @sharok - I'll check into my settings when I get home. I have the X9S.

I see you are a fellow LG OLED E6 owner! :clap:

I'm curious what you mean by "My processor cannot pass 4K and I have a LG OLED TV (E6)."? You mean of your NAS? Or HTPC? If you are streaming files over the network I don't think this matters - the Zidoo processor does the 'heavy lifting' of decoding. It has happily played 4K files (MKV, ISO and MP4) I've thrown at it this way, including correctly triggering HDR mode on the E6.

With the same TV as you (passing the signal thro my Sony AV) I have the output resolution set to Auto and Resolution + refresh rate switching on also. For Blu-ray 1080p ISO's it outputs 1080p. Same for Blu-ray 1080p MKV rips (both 3D and 2D) I've found so far.

I only have a few DVDs (in ISO format) and it does not play these particularly well initially I've found - the aspect ratio is off and menu navigation can be iffy. However during playback I can force the AR to 'Full' or "16:9" (via the Zidoo player options) and they then look OK to my eyes.

I've not checked whether it's actually upscaling these - but either the Zidoo needs to or the TV does, so does it matter I wonder? IMO theE6 does not do a great job of upscaling non-HD sources (I watch very little of these anyway), but DVD's played via the Zidoo are watchable for me (if I scoot my chair back a bit!)
I mean my surround processor. I’d like to connect my Zidoo to my surround processor. I just use USB hard drives connected to Zidoo (No networking or sharing). My surround processor can only pass 1080p and it decodes the audio.
 

Coruja3D

Active Member
I mean my surround processor. I’d like to connect my Zidoo to my surround processor. I just use USB hard drives connected to Zidoo (No networking or sharing). My surround processor can only pass 1080p and it decodes the audio.

Ah OK got you - so "processor" = AV receiver. Time to upgrade? :D
 

sharok

Novice Member
Is it true that while playing 3D MKV (MVS) movies, you need to choose either left or right eye priority in order to watch 3D?

I thought that happens automatically since MVC is frame packed.
In AVS Forum, people have to choose an eye first.
 

sharok

Novice Member
Hi @sharok - I'll check into my settings when I get home. I have the X9S.

I see you are a fellow LG OLED E6 owner! :clap:

I'm curious what you mean by "My processor cannot pass 4K and I have a LG OLED TV (E6)."? You mean of your NAS? Or HTPC? If you are streaming files over the network I don't think this matters - the Zidoo processor does the 'heavy lifting' of decoding. It has happily played 4K files (MKV, ISO and MP4) I've thrown at it this way, including correctly triggering HDR mode on the E6.

With the same TV as you (passing the signal thro my Sony AV) I have the output resolution set to Auto and Resolution + refresh rate switching on also. For Blu-ray 1080p ISO's it outputs 1080p. Same for Blu-ray 1080p MKV rips (both 3D and 2D) I've found so far.

I only have a few DVDs (in ISO format) and it does not play these particularly well initially I've found - the aspect ratio is off and menu navigation can be iffy. However during playback I can force the AR to 'Full' or "16:9" (via the Zidoo player options) and they then look OK to my eyes.

I've not checked whether it's actually upscaling these - but either the Zidoo needs to or the TV does, so does it matter I wonder? IMO theE6 does not do a great job of upscaling non-HD sources (I watch very little of these anyway), but DVD's played via the Zidoo are watchable for me (if I scoot my chair back a bit!)
I thought Zidoo upscales 1080p to 4K. But if it doesn't, then I also can leave it on Auto. my concern was that by leaving it on auto, it will upscale 1080p and 720p to 4K.

How about 3D? Do you have to choose an eye even if your 3D movies are ripped using MKV (frame packed) or is it auto?
 

The latest video from AVForums

Podcast: REL T/9x Subwoofer + Bowers & Wilkins PI7 Reviews, AV Shows in a Pandemic and more
Subscribe to our YouTube channel

Latest News

Hisense announces US TV and soundbar ranges for 2021
  • By Andy Bassett
  • Published
AVForums Podcast: 5th May 2021
  • By Phil Hinton
  • Published
AVForums Movies Podcast: 4th May 2021
  • By Phil Hinton
  • Published
Creative launches Dolby Atmos SXFI Carrier soundbar
  • By Andy Bassett
  • Published
Marvel trailer reveals cinema release dates into 2023
  • By Andy Bassett
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom