Z2 + HCPC + DVI = Disappointment

Jimbobgod

Standard Member
I went to the trouble of buying a 7m DVI cable & setting up a HCPC to use with my Z2 (feeding it a 720p signal), and I have to say, the result was a bit disappointing :( Don't get me wrong, the PQ was very good...just no better than that supplied by my Sony NS930 DVD via component output. Am I missing something?
 

KraGorn

Novice Member
Don't know about missing anything but maybe if you told us the equipment and software you're using in the PC something may become apparent.

FYI, my Radeon 9600-equipped PC running TheaterTek is noticeably better than my Sony 730 in terms of detail and stability.
 

Jimbobgod

Standard Member
I'm using a Radeon 9500 Pro graphics card with the latest drivers. For DVD playback I'm currently using WinDVD Platinum, although I've just got a copy of PowerDVD 5 with another graphics card that I've yet to try...
 

KraGorn

Novice Member
Hmm, not much difference in graphics cards, and while WinDVD isn't my choice (I don't like the softer image it produces) again that too isn't shabby.

You're sure you've got 1:1 mapping, I presume the Z2 displays '720p' in the second menu down (the one below the Input selection).

If that's the case then I have to admit defeat, for now I can't think of any obvious suggestions. Unless that cable is an issue, I know 10m Lindys have caused problems, I use a 5m Lindy and it's fine.

In what way is the image not as good as with your 930?
 

The latest video from AVForums

LG G1 OLED Evo TV and SVS SB-1000 Pro subwoofer reviews, Samsung OLED rumours and more...
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom