YARRA 3DX Owners Thread

gactm

Active Member
I think that before writing about the optical cable approach, I should’ve asked whether or not you checked your HDMI cables. By sending Dolby Digital 5.1 signals via optical cable and the result is proper sound then you get an indication that your HDMI cable and/or Yarra HDMI board input are out of work.
 

Edward Lotz

Novice Member
I have not tested them in a certain way unless I buy new cables. But they are the same cables that I used with the first yarra I had and the work if I send the signal directly to the tv. I can see if I can get ahold of some new hdmi cables to try.
thanks
 

AllenP

Novice Member
I have been having a persistent problem with my Yarra 3DX. I am on my second unit now. Both units have had a problem of "hiccuping", that is intermittently cutting out all sound and sometimes the video signal to the monitor as well. The only solution to this is to turn off the the Yarra and turn it back on.

The Yarra receives a signal through HDMI input from a cable box supplied by Xfinity. The HDMI output on the Yarra is connected to a Samsung TV through its HDMI ARC port.
 

Edward Lotz

Novice Member
I am seeing something similar I use an appletv hdmi then hdmi o Samsung tv and when I turn on the system I get no sound out of the Yarra. I have to turn it off/on again. I know it’s the Yarra cause when this has happened I have disconnected the hdmi cable from the Yarra to tv and connected it to the appletv and sounds works. Connecting it back to Yarra no sound until I cycle Yarra power.

I haven’t seen the video issue. But this has been several issues and like I said. This is my second unit because the hdmi stopped working on the first unit.
 

AllenP

Novice Member
I spent a couple hours on back and forth emails to comhear.com support yesterday. They had me check a few settings and verify that I'm at the latest version of the firmware. There has been no improvement in the hiccuping problem.

This is really disappointing. It's quite annoying to be watching something and have to stop it. Shut everything off. Turn it all back on, and resume watching again.
 

dw5304

Member
so not sure if they have had you try the latest firmware 1.3.4.386 (dev/staging) or if it was the latest public version. the other day I decompiled the yarra3dx application and was able to obtain the dev/staging build.

this version after i flashed it has removed all hdmi issues I was having my self.
some background on it.


staging firmware so im no longer the only one that has access to this ;).
 
Last edited:

gactm

Active Member
It seems that only you’ve succeeded to access the 1.3.4.386 firmware. For the other mortals, the latest version is still 1.2.24.375.
 

gactm

Active Member
......this version after i flashed it has removed all hdmi issues I was having my self.
I’ve read your latest post at indiegogo site on testing the unofficial firmware 1.3.4.386.

Would you care to be a bit more specific on your following findings:

audio input → HDMI
PCM – works no issues
; is this finding valid for stereo and also for multi-channel PCM audio signals?
doby digital – works no issues
; this should be the common behaviour as Yarra 3DX is only provided with a Dolby digital decoder
doby digital plus – broken
doby digital, DTS – works no issues
; these last two findings are a bit unclear - in the first one DTS is working and then it’s not working anymore. As I wrote above, Yarra 3DX is provided only with Dolby digital capable DAC, so DTS signals could not be processed.
doby digital plus, DTS – broken


Thanks in advance for your answers.
 

dw5304

Member
so on the roku
audio settings
PCM side states HDMI ( PCM-stereo) then under audio mode says auto Dolby Digital,DTS)
and it works without an issue. if i go into audio mode and select stereo from audio mode also works so I have to assume Dolby digital, DTS mode works?



or if you have suggestions on how to test this in a better method please let me know what i should be using and what i should be adjusting.
 

Attachments

  • MVIMG_20200425_220104.jpg
    MVIMG_20200425_220104.jpg
    117.9 KB · Views: 72
  • MVIMG_20200425_215839.jpg
    MVIMG_20200425_215839.jpg
    124.9 KB · Views: 70
  • MVIMG_20200425_215854.jpg
    MVIMG_20200425_215854.jpg
    132.5 KB · Views: 67

Aaraujo

Novice Member
Well. Could anyone give a tutorial on how to upgrade the yarra 3dx to this latest firmware you have spoken about? Is it worth upgrading? Does anyone know if an official release will be release one day?
 

dw5304

Member
sure guide on how to do the update.


you will likely need to click the input and select your source again after first boot.
and reajust your settings as audio settings.
 
Last edited:

Aaraujo

Novice Member
Well. I went all the way but the version that showed-up is 1.2.24.375. Either I did something wrong or they have taken the new version from the net.
 

dw5304

Member
Well. I went all the way but the version that showed-up is 1.2.24.375. Either I did something wrong or they have taken the new version from the net.
you likely forgot to change the requested file for https://comhear.gotdns.org/files/yarra3dx/fwver.json

the requested url should be https://comhear.gotdns.org/files/yarra3dx_staging/fwver.json

then you need to change the https://comhear.gotdns.org/files/yarra3dx_staging/comhear_firmware.cmh
as well i think you forgot to change yarra3dx to yarra3dx_staging.
 

Aaraujo

Novice Member
It worked! I have now fw 1.3.4.386 installed. I’m not sure what are the changes or improvements yet. Tks for your help.
 

Andre Le

Novice Member
Can someone provide a link to most recent fw for iOS & instructions please? A change log would be helpful. TIA
 

gactm

Active Member
I’m afraid you’ve arrived too late as the farewell party of Yarra 3DX was some days ago. Comhear took all content down except for their address.

www.yarra3dx.com

I don’t know what you can do.
 
I'm trying to play music from an iPhone 10. Bluetooth connects, phone shows it's playing, but no sound from the unit. Same result sourcing through the RCA jack. Any suggestions/tutorials will be appreciated.
 

bqtran

Novice Member
Following the instructions of the youtube video, I was able to update my soundbar to the latest firmware (1.3.4.386) yesterday evening, so the files are still online even though the comhear website content is no longer there.

I'd recommend you grab it while you can and the site is still online... who knows how much longer it's hosted.

Thanks dw5304!
 

lhs51

Member
Tried several times without success. Every time I hit the Run To Completion button in the first step I get a can't connect message from the Yarra app and can't go any further.
 

The latest video from AVForums

LG C1 OLED TV Best Picture Settings for SDR, HDR and Dolby Vision
Subscribe to our YouTube channel

Latest News

What's new on Sky and NOW UK for August 2021
  • By Andy Bassett
  • Published
Sky Q sports coverage gets live HDR
  • By Andy Bassett
  • Published
AVForums Podcast: 21st July 2021
  • By Phil Hinton
  • Published
Sky and ITV agree long term deal
  • By Andy Bassett
  • Published
Yamaha launches YH-L700A headphone with 3D Sound Field
  • By Andy Bassett
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom