1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Yamaha Z9 with Rel Strata III - help please

Discussion in 'AV Receivers & Amplifiers' started by LindyLou, Jun 4, 2005.

Tags:
  1. LindyLou

    LindyLou
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Recently bought Z9 and trying to use it with Rel Strata III. Had it working with AX1 no problem, but now struggling to get it to sound good - can only get soft wooly bass out of it, with some boom. Have set speakers to small, tried removing hi level connection, played with different cross over frequencies, have switched out Rel filter setting etc etc etc. Tried so many variations, am fed up.

    I contacted Rel but they were no help. Also tried Yamaha and they have no idea either.

    Am at wits end and about to buy an Axiom sub instead! (Have Axiom speakers and they are nice)

    Has anyone got a Z9 working with a Rel and if so, what Rel settings do you have?

    Any ideas in this area would be appreciated.

    Thanks

    Linda
     
  2. Dave H

    Dave H
    Well-known Member

    Joined:
    Aug 20, 2000
    Messages:
    4,373
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Lots of different places!
    Ratings:
    +145
    UP for Lindy:)
     
  3. tan1415

    tan1415
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    that shoudl be pretty straightup I think?

    Is the suboption on in your amp?

    Have you tried connecting it differntly just using one cable from subout to from your sub?
     

Share This Page

Loading...