1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Yamaha RXV1400 Banana plugs?

Discussion in 'AV Receivers & Amplifiers' started by woody123, Dec 9, 2003.

Tags:
  1. woody123

    woody123
    Standard Member

    Joined:
    Jun 30, 2003
    Messages:
    65
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Location:
    Chelmsford
    Ratings:
    +1
    I thought you could use the plugs with this model but looking at the back they seem not to be accepted.

    Is there a way around this please - it would be a nice to have but no biggie if its not possible.

    Good old Yamaha!
     
  2. Steve Rollings

    Steve Rollings
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    You can use banana plugs on RX1400, just push the plug thru the end of the speaker terminal on the back of the amp. I have done this on mine and it works fine, although initially I thought the same as you and Yamaha had done it again (I had an A1 before)
     
  3. wilber

    wilber
    Active Member

    Joined:
    Sep 29, 2002
    Messages:
    1,970
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Ratings:
    +30
    Page 12 of the manual - ignore what it says about uk models being excluded
     
  4. Scotty Boy

    Scotty Boy
    Active Member

    Joined:
    Nov 11, 2003
    Messages:
    1,076
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    38
    Ratings:
    +6
    It's true you know. :)

    Just use a sharp object to take off the middle cover part of where the plugs are.

    That kind of makes no sense, but, meh.
     

Share This Page

Loading...