• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Yamaha rx671: have I fried the internal wiring?

Joe Scaramanga

Active Member
I've had my surround setup working perfectly and untouched for a few years, Yamaha RX671 and Canton speakers and subwoofers, but this morning when I turned on the TV the volume was at max, and as I scrambled to turn it down I thought I heard something pop.
Since then, only two speakers seem to be working, my centre and my back left.
I've tried a test tone and it only plays on the back left. I've tried using the calibration mic and it stops immediately saying it can't detect the first speaker (front left), I've swapped this for another working speaker and still no joy.
All speakers are showing on the front display though which normally wouldn't if a speaker wasn't connected.
My question is, has something been fried inside the receiver that has blown the speaker outputs that aren't working?
Is there a way for me to reset the receiver back to factory settings?
 

dobrykamil

Distinguished Member
Here is procedure for factory reset:
Note: This procedure is done on the front panel of the receiver only.
1. Set the unit to Standby by pressing the Power button.
2. While holding down the Straight button, press the Power button.
3. SP IMP. 8 Ohm Min (Or 6 ohm) will come up on the Front Panel.
4. Press the Right Program Arrow button repeatedly until INIT-CANCEL comes up.
5. Press the Straight Button repeatedly until INIT-ALL comes up.
6. Press the Standby button to turn off the receiver.
7. The next time the receiver is powered on, the factory settings will take effect.


Not sure if the above will make any difference, but worth a try.
 

Joe Scaramanga

Active Member
Thanks for this.
Just realised all my speakers had managed to come undone from the back of the unit. Obviously j noticed this AFTER I did the rest and now I feel like a bit of a pillock.

Can I delete this thread, or can a mod take care of that?
Much appreciated.
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom