• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Yamaha RX-V3067 and PS3 Slim - HD Audio problems

grazzy

Standard Member
Hello,

I've currently got a Yamaha RX-V3067 and a new PS3 Slim, but I'm struggling to get DTS-HD MA onto the receiever - it either says DTS or PCM depending on whether I choose LPCM or Bitstream.

The film is 100% DTS-HD MA as I've connected my PC to the receiever and played the same film, but the PS3 isn't doing it at all.

I've only just bought the PS3 Slim, so whether I should plug it into the internet and see if there are any firmware updates?

Any help would be greatly appreciated

Cheers

Ben
 

jason1wood

Prominent Member
With the PS3 doing the decoding it sends the signal already decoded, as PCM. If you watch the film then go to on scream menu it'll tell you it's HD sound you're getting. To show HD on the receiver it needs a dedicated bluray with HDMI or analogue.
 

andy1249

Distinguished Member
The PS3 slim can bitstream HD audio to your receiver , this is the only way that your receiver is going to display DTS MA audio on the display ,

You can also set the PS3 to decode , that would be LPCM , and this would just show as PCM on the receiver but you will still be hearing the HD audio track , its just the PS3 is decoding is all.

Check you menus again , bitstream for blu ray should be in the settings > BD/DVD settings menu.

Edit , Just in case : The PS3 cannot play HD audio if the BD is a 3D title .... !
 
Last edited:

grazzy

Standard Member
Hello,

Thanks for your reply's.

Ok, I've tried both LPCM and Bitstream, and it does say DTS-HD MA on the info page which is streaming around 5mbps. When it's on DTS, it's around 1.5mbps, but they sound exactly the same.

The film I'm using is Adele - Live at the Royal Albert Hall.

I also went into the audio settings on the ps3, and chose to manually which formats I wanted to play. It wouldn't let me tick DTS-HD MA in the list - for some reason it doesn't think my receiver supports DTS-HD MA.

I've watched this connected to my pc and it literally sounds incredible with the receiver decoding, way better than LPCM. LPCM infact sounds a bit distorted.

The only difference is I've plugged my amp into a different TV. Surely this wouldn't have any effect on whether it can play DTS-HD Master Audio though?

Cheers

Ben
 

andy1249

Distinguished Member
HDMI has EDID , which is a system whereby the HDMI device interrogates or handshakes with the device its connected too in order to set itself up.

So , short answer , yes it could be what the issue is. But the only way this would be an issue is if the amp was in passthrough mode and sending the bitstream straight through to the TV.

So , check the amp is not in passthrough mode , if it is , take it out of passthrough mode and see what happens.
 

grazzy

Standard Member
I've just turned off HDMI passthrough mode and it still not playing ball. The PS3 doesn't think the receiever is capable of DTS-HD MA or even Dolby TrueHD.

I've even tried plugging it in different HDMI inputs on the receiver to see if that made any difference.

Any other things that might be worth a try?

Thanks

Ben
 

andy1249

Distinguished Member
Leave HDMI passthrough off , leave the amp turned on and the TV turned on , turn off the PS3 , turn it on but on power up hold down the button until you see the setup screen on the TV , follow it.

This should force your PS3 to re-negotiate the handshake with the amp and then it should be able to play ball.
 

grazzy

Standard Member
Hey,

Thanks for that. I tried resetting the PS3 initially and it says choose a HDMI output etc which I did, and then it gives you a message asking whether you can see the screen ok or something along those lines. Anyway I figure I must have pushed no because the menu was pretty bad quality.

When I reset it the second time, I said yes and then the entire PS3 menu appeared to be in HD. When I went to the audio settings, it had all of the options ticked and automatically selected bitstream for me.

Thanks for the help!

Ben
 

jason1wood

Prominent Member
Glad you got it sorted. I have a fat old type PS3 and it doesn't pass HD audio through bitstream so I have mine set to PCM. So my advice was slightly wrong. Haha
 

andy1249

Distinguished Member
Glad your up and running:thumbsup:
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom