Yamaha RX-1700 Sounds issues on Freeview

bayf

Standard Member
I have a Samsung LE40M87BD TV with a Yamaha RX-1700 Amp. I have posted this in the Samsung TV page as well but I wondered if it was the amp.

Basically, I can watch freeview, with the TV speakers on with out any trouble. If I am using the amp for the sounds output, it normally works but occasionally the sound drops out. Any thoughts. The Amp is connected to the TV using an HDMI cable and an optical cable for sound coming from the TV to the Amp.

Any thoughts would be gratefully appreciated.


Bayf
 

Andy98765

Distinguished Member
I would get the optical cable checked out. I know many people on this forum state "its digital so expensive cables are not needed" but at the end of the day it often comes down to the mechanical construction of the cable that lets it down.
As your TV can only do Freeview I would suggest getting a quality stereo link instead, it does not have to be expensive. http://www.tvcables.co.uk/cgi-bin/tvcables/PH002.html
 

co55ie

Active Member
the freeview tuner in your Samsung doesnt work properly thats why its most likely cutting the sound out.

Have a look at the threads in the LCD section there is a design fault with the integrated freeview tuner on these sets that Samsung have yet to resolve
 

The latest video from AVForums

Podcast: LG C1 OLED + JBL Synthesis SDR-35 First Thoughts, plus TV Show & Disc Reviews & more
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom