1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Yamaha DSP620RDS Cinema Amp

Discussion in 'AV Receivers & Amplifiers' started by british_cooper, Oct 6, 2002.

Tags:
  1. british_cooper

    british_cooper
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I need help:

    Ive checked the impedence switch !!!!!!!
    Why does my amp cut into standby every time i do something on the remote.
    Is it i have the wrong speakers or something
    When speakers are not switched on it does not cut out
    Any suggestions cheers
     
  2. bob007

    bob007
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Check your wiring, you may have wires touching somewhere causing the amp to shutdown.
     
  3. british_cooper

    british_cooper
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    i dont think its the connections because when you turn sound down.
    It clicks does not turn off and you can turn it up , its when you select another source or mute it
    It cuts out
    Any ideas
     
  4. Reiner

    Reiner
    Active Member

    Joined:
    Jul 16, 2000
    Messages:
    3,315
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    61
    Location:
    Germany
    Ratings:
    +13
    What do you mean by "Ive checked the impedence switch !!!!!!!"?

    You didn't switch it while the unit was on, did you!? :eek:

    Else disconnect the unit completely from the AC mains for a couple of minutes and see if it helps (kind of reset).
     
  5. british_cooper

    british_cooper
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    no i switched impedence switch while unit was off.
    And ive tryed leaving power off for 30 sec like manual says.
    Still no joy.
     

Share This Page

Loading...