Yamaha Controller App (IOS) and RX-V473 receiver problem

Kenap

Novice Member
I have problem with Yamaha IOS Controller App.
Have RX-V473 av receiver, iMac with iTunes, and an iPad3 with IOS7. The Yamaha IOS controller app is latest update v4.00, I have also updated receiver firmware to latest available. The receiver is connected to router via ethernet, set on Network Standby, DHCP on so the IP address is dynamic. My router is set to use the MAC address of the receiver and when I log in to the router it reports the receiver is connected. The receiver works fine via Airplay from iMac/iPad. The controller app works fine when it works.

Problem: the IOS Yamaha Controller app can't detect the receiver, just shows the Demo screen when the receiver is on network standby, and when it is switched on, and when it is on and playing music with Airplay as input.

Solutions tried (unsuccessful):
1. Deleting and re-installing the iPad app v4, still no detection.
2. Using receiver IP addresses (app allows 5), but DHCP on seems to defeat this as IP addresses used are dynamic and seem always outside range I input.
3. Yamaha Australia Support suggested I re-initialise the receiver to factory defaults, turn on network standby and DHCP. Did this, still no detection by the controller app.
4. Did a full new setup for my speakers, network etc. Same detection-fail from the app.

5. Work-around (unsatisfactory): After scouring the V473 manual, I found a suggestion in Troubleshooting (p87): hold down the receiver power button for plus 10 seconds, to "re-initialise" it (this doesn't reset to factory defaults). Then the iPad controller app can detect the receiver. However, if the controller app on the iPad is closed, on re-open it cannot detect the receiver.

I advised Yamaha Aust. Support of this behaviour, asked if it could be a fault in the receiver (still under warranty). Support hasn't replied. Has anyone else had this sort of controller app behaviour? Know of a fix that doesn't require the power button trick every time?
 

C squared

Novice Member
I have the same problem. Going back to my old slower configuration. Frustrating and disappointed in Netgear!
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom