1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Yamaha 2400 with AE Evo 3b Package

Discussion in 'AV Receivers & Amplifiers' started by dvd9, Jul 20, 2004.

Tags:
  1. dvd9

    dvd9
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi, sorry. I'm new to this forum. Just wanted to know something. I read somewhere in this forum that you could damage your speaker if an underpower reciever is used.
    I just bought yamaha 2400 with A.E Evo 3b 5.1 speaker package. The yammy is rated at 120w/c and the max watt for Evo is 150w. Is this the case of underpower?? :confused: I haven't hook up my system yet, still wrapped coz I'm in the middle of moving house.
    Hope somebody could help. :D
     
  2. Radiohead

    Radiohead
    Well-known Member

    Joined:
    Dec 24, 2001
    Messages:
    4,295
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Amazingstoke
    Ratings:
    +433
    You couldn't call the Yamaha underpowered - and if you blow those speakers using that amp your ears are likely to fall off.

    The Yamaha and the AE's will be a good match as well.
     
  3. dvd9

    dvd9
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks alot for the reply. So I guess I am in the safe zone. Can't wait to unwrapped all those speakers and amp.. Being waiting for a while now. Hope it worth the hype!! :laugh:


    P.S : anybody had experience with 2400 and Evo3 ???
     
  4. Dfour

    Dfour
    Active Member

    Joined:
    Jan 19, 2004
    Messages:
    3,998
    Products Owned:
    0
    Products Wanted:
    1
    Trophy Points:
    71
    Location:
    Bracknell
    Ratings:
    +85
    I have the 1400 and Evo3's and they rock :smashin: The only thing that could be improved is the sub buts its still a good sub especially with the rest of the evo set.

    You'll love em :devil:
     

Share This Page

Loading...