XBOX360 network issues with homeplugs and switches

walrusoflove

Standard Member
Ok, so I have alot of devices that need to connect to the internet in my home, some wireless, some wired and I thought I had it all covered until I recently decided to "hardwire" the xbox360 in the living room as the wireless kept dropping out.
I already use home plugs (tplink tlpa201) and had one in the living room which was feeding my bluray player.
I purchased an ethernet switch (addon10/100M Fast ethernet switch) to split out the signal from the homeplug to "feed" my xbox, ps3, bluray player and sky hd box.
Everything's working apart from the xbox which just doesn't want to configure! It recognises the wired connection but the ip and dns etc just doesnt want to know. I went back to wireless and copied all the numbers down then manually entered them for the wired connection. Still no joy!
Ive even assaigned a fixed ip for the xbox in the router setttings. Still no joy!
If I connect the xbox directly to the homeplug it works no problem so I know its a switch issue. Do I need a special type for the xbox?
Any help would be greatly appreciated!!
 

Goooner

Outstanding Member
I use some cheap Orange branded Devolo home plugs with my 360, which work fine, didn't have to do anything with them, just plugged in, it detected the wired network and off I went.
 

walrusoflove

Standard Member
Firstly, thanks for your reply! I was beginning to think no-one was going to respond! lol
However, as I have already stated in my original post, its not a homeplug issue. If I plug diectly into the homeplug then all is well. This is no good for me though, as that homeplug NEEDs to feed the switch, which in turn feeds the other devices! I have a similar set up in my bedroom where a homeplug feeds a swith which feeds three devices so I know the whole system works. Infact it does work downstairs too.. With everything apart from the xbox!! So if ANYONE could help I'd REALLY REALLY appreciate it!
 

Goooner

Outstanding Member
Mine actually runs through a four port switch too (just noticed I hadn't actually put that before, was replying from my iPhone), I'm using this one TP-Link 5-Port 10/100 Unmanaged Mini Desktop Switch (TL-SF1005D) Plastic Case.

I know I had trouble getting an open NAT on the 360, but I can't remember if that was when I was using manual or automatic settings, one way gave me Open and the other Strict. Like I said, it just worked, so not much help for you:(

Have you tried different cables and stuff, just in case you've got a faulty one?
 

walrusoflove

Standard Member
Hmmm well that is curious.
It definitely isnt the cable, I tried another one, nor is it any particular port on my switch as ive tried mixing them up and again, everything works except the xbox. Maybe my particular switch isn't comaptible with xbox for some unknown reason. I even tried the switch from upstairs but it is also an addon albeit the previous version..
Might have to try another brand of switch..
Thanks for your reply once again mate, I would appreciate you posting your various settings to see if that will help although I know the ip adress will be different as that is assigned by the router...
Just to clarify, is your setup as follows..
Router-homeplug-homeplug-switch-xbox and other devices..?
 

Goooner

Outstanding Member
Yep, that's exactly how mine's connected.

Basic settings, I've got

IP settings - Automatic

IP Address 192.***.*.**

Subnet Mask 255.255.255.0

Gateway 192.***.*.***

DNS Settings - Automatic

Primary DNS - same as Gateway

Secondary DNS - 0.0.0.0

All Additional Settings are listed as "Not Set"

Hope that's of use.
 

The latest video from AVForums

Rocky 4K, Creed 3 and boxing movies, Shazam 2, 65 trumping Jurassic World Dominion, + Picard & Mando
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom