swizz1119

Novice Member
I have a Lg oled c9 a denon x2500h receiver and an xbox one x to use as a blu ray player i find when using the xbox when i watch some 4k blu ray movies in HDR i get some flashing on the screen particularly on the top and the bottom of the screen very noticeable when watching movies in letterbox format but when i watch the same movie (solo) on Disney + there is nothing and it sometimes happens on Netflix. i know its not the tvs fault as i tried the same movie through the app on the TV and it works perfectly. Does anyone have anything like this happen to them.
 

Pooon

Distinguished Member
not experienced that myself but I also have a denon amp and it seemed quite fussy with what hdmi cable it wanted otherwise I go no picture at all. Also check all of the various menus that the denon has and make sure all the settings look right for 4k pass through etc
 

swizz1119

Novice Member
not experienced that myself but I also have a denon amp and it seemed quite fussy with what hdmi cable it wanted otherwise I go no picture at all. Also check all of the various menus that the denon has and make sure all the settings look right for 4k pass through etc

I have actually just bypassed the amp altogether to see if it was the receivers problem it still does it when i just plug the hdmi from the xbox into the tv. I have bought new hdmi 2.1 cables because i just realized that the lg uses hdmi 2.1 so im hoping that could do the trick
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom