X3700H LG G1 77 & Xbox X 4K 120

madcal

Novice Member
Afternoon all,

New kit arrived, as per title.

If I connect the Xbox direct to the TV then it will let me select 4K120.

However if I go via the X3700H I am limited to 60Hz.

I have set the option on the Denon for 8K signals, cannot see anything else which could help.

I have an 8k compatible long cable from the AVR to the TV. From the Xbox to the AVR I am using the cable which came with the Xbox.

My serial number on the Denon is way past the 70001 where they update the hardware.

Any ideas please how I can get 4k120 via the Denon?

Thank you
 

TechyMike

Well-known Member
Xbox is connected to the correct HDMI input for 4K/120 on the amp?
I assume it is but you never know.
 

TechyMike

Well-known Member
I am thinking of getting the same amp. I have a PS5 and a LG C2 77 which works at 4k/120.
I know there were problems with the Xbox but as you said the new builds of the 3700 should have solved that issue.
 

madcal

Novice Member
I will go check the inputs, I have it connected to the one marked “GAME”.

I thought they were all 120Hz but maybe I made a schoolboy assumption…

Thanks again.

PS latest firmware on all devices.
 

madcal

Novice Member
The only mentions in the manual of 120Hz are as follows:

51F4280F-0936-49F7-9F1D-0772E6822E42.jpeg
1AA4EAB8-9B83-4689-A62D-4C87436F86CF.jpeg
 

TechyMike

Well-known Member
"I will go check the inputs, I have it connected to the one marked “GAME”."

That is not the right one.

Needs to go into the 8K IN one.

At least you will be sorted now!!!:clap:
 

TechyMike

Well-known Member
1654002237546.png
 

TechyMike

Well-known Member
Pleased you have it working.

Is the screen above from the XBox?
 

madcal

Novice Member
Yes. Not sure why the Dolby vision thing is out. We will go fiddle with the settings.

Whilst I have you here….

When I play content from e.g. am the AppleTV app on the TV or the sky box plugged in do I have to select the sound “mode” on the amp or should it just figure out it is getting Dolby Digital or whatever? Seems at the moment the amp just sets things to Stereo then I have to press some buttons to make it do 7.1?

Probably user ineptitude!
 

TechyMike

Well-known Member
You need to set up the sound output from the devices so the correct format is sent to the amp.

Sky does 5.1 for some of the channels so the amp should show 5.1 if the sky is setup to send a 5.1 signal.

A case of finding the correct menus in the devices.:)
 

The latest video from AVForums

Samsung QN95B 4K QLED TV Review
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom