Quantcast

x vision pro quadcopter

edwin wright

Novice Member
all the lights are flashing,camera works but it wont move and rotors don't rotate,can anyone give me any advice what i am doing wrong
eddie
 

rickyt

Active Member
Not much information to go on here. Is it new? or have you bought it second hand? has it ever worked? Are you activating the motors? Some drones are activated by moving the sticks lower-inward or lower outward. Not sure about your particular drone but they seem problematic.
There has already been a thread about this model
X Vision Pro Quadcopter

When testing your drone to see if the motors spin etc .......take the props off . Alot safer to do this or risk a accident if it suddenly takes off.
 

edwin wright

Novice Member
I bought it 6 months ago never unpacked it till yesterday. Bought brand new. Can't get engines to go.
Every thing light's up and camera shows picture. Camera also does not move.Do I strip it down to check all wiring?
 

rickyt

Active Member
Did you read the post from the link above? The guy gave up on his and sent it back . Maybe faulty!
 

noiseboy72

Distinguished Member
Could be faulty, could be a faulty battery, not sat on a flat surface so that the IMU doesn't initialise...

Lots of people have had the same problem, so you are not alone. This suggests it's not a fault, but that it's very fussy about its start up procedure.

The manual: https://www.bhphotovideo.com/lit_files/128615.pdf suggests you might need to calibrate the compass prior to flying. This is detailed in the manual.
 

edwin wright

Novice Member
managed to get it going now.soon as i get a good day i am going to get it in the air.
One thing i will ask is now i have it going how do i get camera to tilt. I want to use the camera to look at the ground as i do metal detecting. I would hope it will help me
 

Similar threads

Top Bottom