Quantcast

Worse picture after official (manual) firmware update on 55UM7450PLA

Tvrdi

Novice Member
Hi,
Maybe I didnt noticed that before. But when watching TV programs (DTV, via antenna, DVB-T2/h265) I noticed that logos arent super crisp, sometimes like they have those artefacts around them, noticable specially when looking from close, like when you have in tube streaming with bad source, also similar artefacts can be seen when looking at TV telops with lots fo jpegs/inforgraphics). Its noticable on pictures (human faces) but less. Like some pixelisation/bad streaming is going on.. Some channels are better but......the last two updates (newer than my stock firmware) came with minor fixes (says nothing about processing or picture). What do you think? I have 55UM 7450PLA LED TV. I manually updated from 04.07.20 to 04.71.25 (firmware downloaded from official LG page for this model). I found an original firmware file but Im not sure If I can install that over the never. Both are around 1GB heavy. The latest firmware was downloaded from official LG site. I foind out on some russian site that it is probably a test firmware which for some reason LG put as official final, on their own support/software site for my TV. How this is possible? Over OTA I didnt receive nothing btw.....
 

Clem_Dye

Distinguished Member
You can’t downgrade firmware, or roll back to an earlier version. Have you checked your picture settings? Is it possible that they've been reset to factory defaults? My LG TV seems picky when it comes to detecting new firmware over the wire, but I always prefer to update via USB.

You could try a factory reset to see if that helps, and if that doesn’t help try contacting LG.

Clem
 

Tvrdi

Novice Member
Yes, I did reset the settings (reset to initial settings option) and changed all kinds of picture settings but that didnt help. I also did a cold reboot. I cant find a factory reset option in the menu of the TV. Im affraid LG didnt think about that so ppl can revert the software to factory defaults. What puzzles me the most is that the LG uploaded links for the test/beta firmware to the OFFICIAL support page for my TV without noticing its not official version. I found out that elsewhere. Its mind blowing. I already contacted them via mail but no respons and their chat is more or less placeholder.
 
Last edited:

Clem_Dye

Distinguished Member
Are you sure that you installed beta software? I’ve never known major manufacturers to publish links to their beta software unless it was to invite feedback, and they carry big warnings about possible consequences. Even then, there would be increments in internal version numbering to distinguish releases. LG may take a while to respond to email, but in my experience they always do. It’s possible perhaps that you came across an internal site that wouldn’t normally grant public access. I’ve only ever downloaded software from the lg.com website. If you’re downloaded it from elsewhere then all bets are off. Your only hope would be that LG will release updated firmware for your TV at some point in the future.

There are regional differences in models. Perhaps you loaded one for a different region. It might well be possible to install software from an LG site in Russia, but I certainly wouldn’t trust it.

Clem
 

Tvrdi

Novice Member
Nope. All Eu versions are the same. Btw lihe I mentioned earlier, I downloaded firmware from official lg.com web. Firmware for my exact model. Website is the same for on ex. UK and Croatia. Maybe the crappy mpeg compression (via dtv antenna (x265/dvbt2) was there before update but I doubt...like any txt, logos are smoothed a bit...then clear and so on..lije somf hesvy compression varies live..
 

Tvrdi

Novice Member
Its not the settings I tried everything. Besides it was ok before update. Subtitles and text in general is the worst. Edges are "eaten a bit", they are slightly jagged...some worse some a bit better....blurry a bit. Logos also but not so much and some are better depending of the station. And the degradation is not constant but varies....you can definitely change how the image processor works in firmware and they did it in the worst way. My TV isnt faulty because the pic was perfect and titles super crisp before the firmware update.
 
Last edited:

Clem_Dye

Distinguished Member
Well, you have an issue of some sort now. It’s just possible that the new firmware had highlighted an issue masked by the older version. Are you sure that you’re watching the same channels — SD, rather than HD?

Clem
 

Tvrdi

Novice Member
Nothing was masked. Picture was better before, specially subs. The firmware which I downloaded from the LG site inst yet official and could not be found via regular OTA udpade. Why it was put on LG site I dont know.
 

Clem_Dye

Distinguished Member
Masked: hidden/obscured/not obvious.

OTA downloads are no longer provided. Updates are via the Internet or via USB. Your TV will either take care of updates automatically, if so configured, or prompt you to update. I always disable automatic updates, wait for my TV to detect a new update, then I update via USB at my convenience.

If the picture is worse then you could have a fault, especially if picture settings won’t fix it. Coincidence, perhaps.

Clem
 

Tvrdi

Novice Member
When I said OTA I was thinking of updates via internet (from TV menu). I never use automatic updates but manually update via internet. In the past that is how I updated my old LG LED TV without any issues. The picture itself isnt worse (or I dont notice that). Its the logos, subs, text in general where I noticed bad processing is going on. More noticable via DTV (antenna, dvbt2 hevc) than when playing from external HDD (but still even there my subs arent crisp, they are somehow lower res and a bit blurry, just a bit). Some pgrograms are better and the bad processing is variable, one moment channel logo is ok and few mins later - its not. Firmware can influence how the picture or graphics will be processed. Coincidence isnt as just a seconds after update I noticed the change. TV out of the box was OK. BTW, like I said earlier, on some AV russian forum (they are pretty good with software from my experience) they reported that the firmware I downloaded from LG official page is TEST version. Latest official is 04.70.20. Why we cant accept that someone in LG made an error and released unofficial firmware on offical page. They made so many stupid thing in the past. This isnt the first time.
 
Last edited:

larkone

Distinguished Member
You loaded test (beta) firmware :facepalm:
 

Tvrdi

Novice Member
You loaded test (beta) firmware :facepalm:
Did you read my first post? Or any post? I downloaded this firmware from OFFICIAL LG SUPPORT PAGE. There you can only download this (test/beta?) latest version of firmware. There is no notice its beta. That is the whole point of this problem.
BTW , here is the link. Its ENG version bit its the same with croatian just translated.
 

LDeacon

Member
I'm in a similar boat. I installed the same firmware on my UM7500, and now I can't get HDR! The picture flashes black as though to enable it, although it doesn't! Also switch source seems slower.
It was downloaded from here:
 

Tvrdi

Novice Member
Thank you for your report Deacon. This firmware is definitely faulty. I downloaded from the same offical LG page. I just cannot understand why such (test?) firmware was uploaded on official LG support page. Its their fault! I contacted LG Croatia and they advised me to wait for next official update and then flash it. I never had problems with LG updates on my old LG LED TV. This FW is btw for all the UM7xxx and SM8xxx series. I imagine we are not the only one who got it from LG official page and installed.
 

LDeacon

Member
Yea it's a massive pain. Not happy. I was hoping it would fix the freesat hd picture issue or something. And who knows when the next update will even be!
 

Tvrdi

Novice Member
It seams its not the first time they messed up with firmwares. It happened with OTa versions also.
On top of that somehow I think this update we installed is ineed official and it will be OTA soon. Disaster.
 

jalaneme

Standard Member
I'm in a similar boat. I installed the same firmware on my UM7500, and now I can't get HDR! The picture flashes black as though to enable it, although it doesn't! Also switch source seems slower.
It was downloaded from here:
what firmware version did you install and is there a safe firmware to install? is there a place to download previous safe firmwares for this TV? I want to get the same tv will be setting it up, would it be safe to install the firmware via the tv?
 

LDeacon

Member
what firmware version did you install and is there a safe firmware to install? is there a place to download previous safe firmwares for this TV? I want to get the same tv will be setting it up, would it be safe to install the firmware via the tv?
I installed 04.71.25 from their official product support page! Wish I didn't! And I can't find previous versions and not sure you can downgrade anyway.
The only thing I can do now is wait for the next update through the tv to come out. But ye updating through the tv will be fine, just don't manually install any firmware you find!
 

jalaneme

Standard Member
note taken and thanks for the heads up on what firmware you installed.
 

Similar threads

Trending threads

Latest News

BenQ launches new Home Cinema and Gaming projectors
  • By Andy Bassett
  • Published
Acorn TV streaming service to launch in UK
  • By Andy Bassett
  • Published
LG UK 2020 TV rollout and prices revealed
  • By Andy Bassett
  • Published
TV shipment forecasts slashed for Q2 2020
  • By Andy Bassett
  • Published
Samsung Display to quit LCD production
  • By Andy Bassett
  • Published
Top Bottom