Wireless setup problem

jlcrawford

Active Member
I have just been reading about mainlobby and the fantastic setups some guys have in using wi fi servers as home media centers.
I have wireless internet through a USRobotics wireless router connected to my cable modem and have just set up a home network using 1 pc and 1 laptop.
My problem is that although my network works fine from the desktop PC the laptop sees the network and lists both itself and the desktop yet will not allow me access to the desktop giving an error message saying it is not accessible-running xp home on the laptop and xppro on the desktop,both c drives are shared.
It is very strange- any ideas
 

MikeTV

Well-known Member
It could be the inbuilt XP firewall, preventing access. Otherwise it could be permissions on the folder. One of these two items are usually the culprits. There shouldn't be any problem connecting XP Home and XP Pro together.

My guess is that both machines belong to the same workgroup? (eg. "MSHome", or "workgroup").

If changing permissions, you probably want to add "everyone" to the folder/drive permissions.

Then make sure that the firewall isn't running on the network connection on either machine.

Of course, you will then be lowering the security of the machines, and so it may be best to configure it back to normal again before connecting to the internet.

It is possible to configure your firewalls to allow file sharing, and also to set the permissons more securely, but it's a bit more complicated. It is worth trying the above just as a test first.
 

jlcrawford

Active Member
well I have spent two hours and am no further forward.
My main pc can access the network and see the c drive on the laptop.The laptop sees a network but cannot list the computers within.I do not have Ieee authentication turned on on any machine and all pcs are in the same workgroup and have file sharing enabled with no retrictions.
I am using cheap usb wireless adapters but they have worked fine for over a year with my US robotics wireless router.This is configurable and I dont understand it much at all but it is letting the desktop see the laptop so can there be anything wrong with its settings
Anyone have any suggestions?
 

rhinoman

Well-known Member
1. You need the same username and password on both machines or you wont be able to access the other machines but,

2. If your using DHCP make sure that you haven't been handed a duff ip and different subnet, try fixed ips and put your dns servers as your isp's
 

pringtef

Active Member
There's quite a few that could cause a problem. I'd suggest first of all, checking to see if the laptop can actually see the desktop at all.

Using the laptop, from DOS type the following

ping desktopname

If it resolves the name to an IP address, then name resolution is working properly.

Also try

ping ipaddressofdesktop

If you get a reply, from either of these two pings, then it is also able to communicate with the desktop.

If you're not getting a reply, then it is likely that the firewall on your system is blocking comunication, check the settings for that.

Otherwise, next step would be to try to create an IPC connection with the desktop.

net use \\ipaddressofdesktop\ipc$ /user:ipaddressofdesktop\accountname password

For "accountname", this must be an account on the desktop, preferably the administrator one, or one with administrative rights

For "password", use the password for the above account

If you get a successful connection, then it would appear to be a name resolution/browsing issue. In that case, enable LMHOSTS lookup, and put an entry in for the desktop, and it's ip address there. Restart the PC.

Another thing you can try (still from the laptop) is to go to the start menu in xp, select run, and type in \\ipaddressofdesktop then OK.

Let me know how you get on, becomes a lot more easier to figure it out once we've identified how far it is getting with communication.
 

Matt Horne

Well-known Member
Do you have a software firewall like sygate ?

If you do go in and change the settings to allow access from other computers in your workgroup. I had the same issue.. my xp pro laptop could access my win 2000 music server, but I could no do the reverse until I checked out my firewall.. a quick way to check would be to open your software firewall and then try accessing the drive.

Also I am using fixed IP's for all of my pc's and a variety of wired/wireless link via a linksys router.

Matt
 

jlcrawford

Active Member
Thanks for all the help
I found a firewall running inside my virus scan programme,this then opened another door as my laptop was asked for a username and password to access the XP pro desktop.
I managed to get it sorted but again with difficulty as I ended up with two users on the desktop and also now my htpc(bought another card today).
I dont know how to use static IPs sowould this make things more stable?
At the mo I managed to map all drives on all pcs sonext I will try main lobby + ML server
What fun!!
Cheers to all and I'll be pestering again soon no doubt
 

rhinoman

Well-known Member
DHCP or static ips is largly a matter of preference, some people will advocate either. With a small network its not that much hassle to run statics and it saves the occaisional duff ip when the dhcp server is not available.

Static ip's just need the gateway - machine or router ip for the internet, and the dns servers, this could be the gateway again or the dns servers of your isp.

If you want a machine to auto logon when there is more than one account on it, you can download tweak ui powertoy from Microsoft.
 

Steve Bate

Novice Member
Hi Jeff,

Glad to see I'm not the only MainLobby user here!!

I've got ML MLS DVDL MuL WeatherLobby DVDLPPC MuLPPC and find it excellent, I use my PDA wirelessly with DVDLPPC to control my HTPC for DVDLobby and MuLPPC to control my AudioPC.

Just need to get a fast enough wireless conection to stream video and then it's DVDLobby everywhere!!

Steve
 

Similar threads

The latest video from AVForums

The Best Amazon, Disney+, Sky & NowTV Movies and TV Shows Coming in October 2020. Tom's Thumbs.
Top Bottom