Windows won't read 1 USB stick, but will read another

cymruoasis

Active Member
I have 2 USB sticks. I forrmated one of them to FAT32 this afternoon in order to sort out a problem with XMBC on my Apple TV. Then started the process to create the 'patchstick' for installing XMBC on my ATV. I left the room while the process was happening.

When I came back the software that was creating the 'patchstick' had a 'Not Responding' error and my USB stick was no longer showing as connected. I ejected it, and inserted it again, but it would not read it. I then tried another USB stick and that showed up fine.

I tried the one that wasn't being read again, and there is a noise as though it's being detected but it won't load on the screen, and it won't show up under Computer. What is strange however, is that it does show up under Devices and Printers.

Any ideas? :confused:
 

EndlessWaves

Distinguished Member
I don't know what the 'patchstick' process involves, but it may just be the file system has gone wonky. Have a look under disk management (just down from device manager) and if you can see it there you'll be able to reformat it.
 

cymruoasis

Active Member
in disc management, right click on the drive/partition and select format.

Curly

Just clicked to format the but where there is something saved and I get an error saying 'The system cannot find the file specified'. Do you reckon the pen drive's knackered?
 

cymruoasis

Active Member
My cousin has a Mac, but doesn't live close enough for me to just pop over to give it a go unfortunately haha. Everyone else I know has a PC.

Ok, I think the problem is that the pen drive somehow isn't assinged to a drive letter and there won't show up in Computer.

I've tried to assign it a letter in Disk Management but I get the following error:

Error01.jpg


I've then tried this:

Error02.jpg


Doesn't seem to work either.

Has anyone got any other ideas?
 

The latest video from AVForums

Are the TCL MiniLED TVs better than OLED? TCL Interview with Marek Maciejewski | AVForums Podcast
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom