Windows RDS and Thin Client Headache!!!

rushdink

Standard Member
Having a bit of a problem at the moment with Windows RDS and using Thin Clients to connect to the server.

Heres a bit of background to the setup. I've just setup a server running the Windows Remote Desktop Services (called RDS-01) at Site A which is our main site. We have a remote site (Site B) which I want to roll out thin clients too and have them use RDP thruogh the thin client to connect back to RDS-01 at Site A.

Site A's network is on a different subnet to Site B, site is 192.168.100.0 and Site B operates on 192.168.120.0, they are connected via a VPN through 2 Draytek 2820n routers with no actual physical firewall.

I'm having massive problems getting a connection through the Wyse terminal that I've bought at Site B.
I can ping the RDS-01 server fine, do a tracert and its getting there fine, I can even RDP to the server from some normal desktop machines at Site B so it doesnt look like the server is blocking RDP connections or anything it just won't let me connect through a thin client and it's driving me mad now!
I've looked at the ports open on the router at Site A and i've set up port forwarding for 3388/3389 (Tried every combination possible), but it still wont' connect. I've tried connecting via machine name, and via IP to no avail.

Am I overlooking something really simple here? I'm a bit new to the whole RDS setup etc so am just learning this all as I go. Not sure if its worth noting that at Site A I can connect up to RDS-01 fine through a Thin Client, I just appear to be getting the problem from Site B.

Is it to do with the subnets? The ports? a VPN issue? A firewall issue? Really hit a brick wall with this! (RDS-01 is running 2008R2 btw)
 
Last edited:

SUMMONER

Well-known Member
Please take my comments with a pinch of salt, as I know less than nothing about Windows RDS.

If a Windows PC at site B can connect then the thin clients should be able connect too. After all they are both on the same subnet, use the same VPN connection and pass through the same router - no? Check your settings on the Wyse terminals again.

Have you ever successfully connected this make/model of thin client to the RDS server?
 
Last edited:

rushdink

Standard Member
Yeh thats exactly what I couldn't understand. As it turns out I've sorted the issue now, not quite sure what triggered it to work as i'd changed about 20 settings.
 

ncmoody

Novice Member
Horrible suspision that the subnets are the problem.

Have you taken a thin client to site A and proved it to work there, on the site A subnet.
This would prove everything is setup OK.

If then when you take it to site B and change the IP it does not work you have less that 10% of the system to faultfind.
 

rushdink

Standard Member
Yeh I work out of Site A and the thin clients worked flawlessly there so I was just expecting it to be a simple plug in and go job from Site B but it wasn't! As stated before though I seem to have got it working now!
 

rushdink

Standard Member
Yeh me too, been at it since 9:30 this morning, was just about to call it a day then got it going at 3:00pm!
Relieved isn't the word!

Still having a problem with the external access though using the RD Web Access web portal.
The problem I'm having is that for some reason when people are clicking the link for 'Remote Desktop' when they log in it is basically saying 'Remote Desktop cannot find computer .....' as per the screenshot below.



Anyone any ideas for this one?
 

mickevh

Distinguished Member
If your subnet masks on both sites are "255.255.255.0," then they are not part of the same subnet.

If your site-to-site VPN tunnel is totally transparent and pass through, then you could set up both sites so that they are part of the same subnet, however I wouldn't want to do that as both sites would then be part of the same broadcast domain which means all broadcast traffic has to transit the tunnel and a get sprayed around each site.

I'd prefer to keep the subnets separate and set up some reciprocal routing rules so ethat I could pick and choose what traffic transits between the two site (and localise the broadcast traffic.)

Having said that, the screentshot looks more like a name resolution issue.

How to crack this is going to "depend" on a lot of factors, not least the capabilities of your VPN endpoint devices and your routing topology.

To start, can you paste up a "IPCONFIG /ALL" from a workstation on each site.
 

rushdink

Standard Member
mickevh - The screenshot is relating to a different issue with our RDS setup. The initial issue of not being able to connect with a thin client is resolved now thankfully.

This screenshot relates to external access through the RDS Web Access site we have setup. Unless your instructions are in relation to that and Ive completely misunderstood you!?
 

mickevh

Distinguished Member
Cool. Actually, it says in an earlier post which I hadn't read closely enough, that you've solved your problem with comms. so ignore me.
 

The latest video from AVForums

Podcast: Q Acoustics Q3030i, Humax Aura, Roku Streambar & WandaVision Reviews and more...
Top Bottom