Question Windows PC not fully shutting down

AlanX

Active Member
For a couple of years now I've tolerated a problem with my Chillblast PC (Windows 10 Pro, fully updated), where the PC doesn't fully shut down. The OS shuts down fine (most times), and I can hear some the fans have stopped. But at least one fan is still running, and my 'on' light is still on (but disk activity drops). I have to hold down the 'off' button for 5+ seconds to force it to go to sleep properly.
It's not a power supply problem, because that has been changed since the problem started. I can't immediately see anything wrong with the BIOS settings.
I'm suspecting a corrupted driver, but which one? I'm wary of tinkering with drivers in case I end up with a non-working system - at least it works at the moment, just rather inconvenient.
Any thoughts, before I get it up on the bench? Thanks as always.
 

LV426

Administrator
Staff member
This isn't a recommendation nor suggestion about fixing the actual issue. But IF you decide that it's worth "playing" with your drivers (or anything else that's in the software) you can insure yourself against "breaking" the system by taking a HDD image before you begin.

I use Macrium Reflect free edition for this purpose. It comes with a portable (very limited) edition of Windows - WindowsPE. You install the package on your HDD and at the same time create bootable media with WinPE and Macrium on it (it's a guided process). Then you create your image. Put all of this onto external bootable media. You will need a drive big enough to contain all the data (note - not total partition sizes) that's present on your system.

Now, tinker away.

If a restore is necessary, you tell the BIOS to boot from the external drive and restore your system image back to your HDD from there using the PE operating system plus the accompanying Reflect software and the image file you created. And it's exactly back to before you started.
 

DavidG1

Active Member
here are a list of things you can try. You may well be right that a rogue driver/program could be the problem

It may also be worth looking in the event log to see if there is something delaying the shutdown
 

Atomic77

Active Member
That's what I would do make sure there is nothing running that doesn't need to be before turning the computer off.
 

Kapkirk

Active Member
For a couple of years now I've tolerated a problem with my Chillblast PC (Windows 10 Pro, fully updated), where the PC doesn't fully shut down. The OS shuts down fine (most times), and I can hear some the fans have stopped. But at least one fan is still running, and my 'on' light is still on (but disk activity drops). I have to hold down the 'off' button for 5+ seconds to force it to go to sleep properly.
It's not a power supply problem, because that has been changed since the problem started. I can't immediately see anything wrong with the BIOS settings.
I'm suspecting a corrupted driver, but which one? I'm wary of tinkering with drivers in case I end up with a non-working system - at least it works at the moment, just rather inconvenient.
Any thoughts, before I get it up on the bench? Thanks as always.
Easiest way to find out what is ACTUALLY causing this is to look in the windows "system" log, you can do this from computer management and select windows logs/system, in the system log you will see time stamped errors when shutting down and therefore trace which driver or software is causing the system to "Hang" and then go about removing or re-loading it.
 

jimscreechy

Active Member
Before you do any of the above, I think your PC needs a good blowout with a compressor, or if you don't have that, a can of air duster. I suspect what is happening is your system or some component is retaining heat, perhaps because of a dust blockage so is running hotter than usual. This is causing the fan in question to stay on even when the system is shutdown to dissipate this heat. Normally if this is the case then eventually (after the troublesome component has cooled) the system will completely shutdown as normal.

It is probably the easiest thing to check so do it first, and since having a clean internal case is always a good idea, make sure yours is. Don't forget to blow out the CPU cooler, in fact blow the dust out of everything. then try booting and shutting it down.

Hope this helps
 

techquest

Well-known Member
Try a selective startup and then start and shortly after shutdown. Do you still have the same problem? Let us know
  1. Press Windows Key+R.
  2. Type msconfig and press Enter.
  3. Choose Selective startup and uncheck Load startup items.

    selective810_1.jpg
  1. Select the Services tab.Check Hide all Microsoft services. Click Disable all.

    selective810_2.jpg


  2. Click Apply then click OK.
  3. Click Restart.
 

Rickbale

Banned
For a couple of years now I've tolerated a problem with my Chillblast PC (Windows 10 Pro, fully updated), where the PC doesn't fully shut down. The OS shuts down fine (most times), and I can hear some the fans have stopped. But at least one fan is still running, and my 'on' light is still on (but disk activity drops). I have to hold down the 'off' button for 5+ seconds to force it to go to sleep properly.
It's not a power supply problem, because that has been changed since the problem started. I can't immediately see anything wrong with the BIOS settings.
I'm suspecting a corrupted driver, but which one? I'm wary of tinkering with drivers in case I end up with a non-working system - at least it works at the moment, just rather inconvenient.
Any thoughts, before I get it up on the bench? Thanks as always.


Hello

I am here to help you on this problem.

There can be several causes but to start with, you can try the following. Please try these options one by one and check after each option.

1. Troubleshoot Power
Type troubleshoot in Cortana Search > Click Troubleshoot > Scroll down > Click Power > Run the troubleshooter > Follow on-screen direction.

2. Restore Default for Power Settings
Windows Key+I > System > Power & sleep > Click Additional power settings to open Power options > Click Change Plan Settings > Click Restore default settings for this plan

3. Disable Fast Startup
Reach to Power options as in the previous step > Click Choose what the power buttons do > Click Change settings that are currently unavailable > Scroll down to Shutdown settings and uncheck Turn on fast startup > Click Save changes

4. Uninstall / Install Battery Driver (Only for laptops)
Shut down your computer > Detach power chord > Remove battery (if fixed no need to remove) > Attach power chord > Reboot your computer
Windows Key+X > Device Manager > Expand Batteries > Right-click Microsoft ACPI-Compliant System > Uninstall > Shutdown the computer > Remove the power chord > Attach your battery > Attach your power chord > Reboot the computer to automatically install the driver

Regards,
Rick Bale
 

AlanX

Active Member
Hi Rick,
Firstly, a big thank you for coming in to help me on this. Following your advice, this is what I've done:

Option1: Couldn't find Cortana search. Instead went to Control Panel, and searched on 'Troubleshoot Power'. Got "Find and fix problems with your computer's power settings". Advanced >> Apply repairs automatically. Changed setting from High Performance to a 'more efficient power plan'. That showed Power Plan as 'fixed'. Rebooted twice. No change.

2. Was set to Balanced (Recommended). Restored defaults and saved. Rebooted twice. No change.

3. Fast Startup was already disabled from previous attempts at a fix. Tried toggling it on, then reboot, then toggle off and reboot. Rebooted twice. No change.

4. Not applicable as this is a desktop machine.

If nothing else, this has enabled me to eliminate a few more sources of the problem, so thank you for that.

I've just spotted all the suggestions for other people, so apologies to them for seemingly ignoring their input (somehow missed the notification emails). So I've now got a few more things to try.

Thank you all!
 

AlanX

Active Member
To all who have helped here. I'm now going through a few of the suggestions that have been kindly offered.
Something I didn't mention in my original post .... If, instead of hitting Power >> Shut down on the Windows screen, I hit Power >> Restart, it goes through the whole process. Windows shuts down, all the fans stop, the power light goes out, all as it should be. A few seconds later it kicks back into life (but of course that's not what I want when trying to shut down!). Does this point to the source of the problem in any way?
 

AlanX

Active Member
Before you do any of the above, I think your PC needs a good blowout with a compressor,
Thanks, but I don't think that's it. Firstly, the box was blown through not that long ago. Secondly, the power light and one or more of the fans will stay on all night if I leave it, so I don't think it's a cooling down problem. But that's always a good suggestion.
 

AlanX

Active Member
Many thanks, techquest, for your detailed description of what to try. I've tried both of your suggestions, regrettably without success.
I'm sure this is all narrowing down on the source of the problem, so all useful input, for which I'm grateful.
 

jimscreechy

Active Member
One thing I can say with a fair amount of certainty, is that it is not a Windows, or driver issue and nothing OS related will fix this.

Some software like Asus Ai suite can be used to control and configure the bios that's true, but once the OS isn't loaded (like before startup or after shutdown) the bios operates independently, and only uses the settings that the OS has set.

I would recommend you clear the bios (reset to defaults). That should fixt the problem but! If that doesn't I would suggest flashing the bios with the latest available version.
 

AlanX

Active Member
Thanks, jimschreechy.
The problem started several years after I received the PC - it just 'happened'. So if it's BIOS, it wasn't related to the original installed BIOS. I then thought it could have got corrupted, but the problem was still there after I flashed the BIOS a year or so ago. So I'm rather doubting that.
I'll try resetting the BIOS to defaults and let you know (but I think it may already be at default, apart from boot order). Then perhaps another flash.
Thanks for your input on this - much appreciated.
 

AlanX

Active Member
Well, I took a look at the BIOS settings (Asus P8Z77-V m/board, BIOS version 2104), and discovered that my C: drive wasn't in the boot list. It was trying to boot from a supplementary HDD, and presumably, not finding the OS, went searching through all the drives for it! Couldn't see my C: (SSD) in the boot options at all, and couldn't see a way to add it from the drive list. But when I then set the BIOS to default settings, the C: drive popped up as the first boot device!
I was so hoping this would solve the problem, but alas it didn't. I'm almost coming to the conclusion that it's hardware. I might try disconnecting as many peripherals as possible, to see if one of them is not letting go.
 

Bolosun

Member
Have you tried clearing the CMOS using the jumper on the motherboard? Also check to see if there is any fane delay control in the bios.
 

AlanX

Active Member
I've done a reset to defaults in the BIOS, and what I've read says that this resets the CMOS for most systems. May not be the case for Asus, but any further investigation will have to wait until I get the thing up on the bench.
No fan delay control in the BIOS.
As things stand, it's less trouble to live with the problem than it is to resolve it!
 

The latest video from AVForums

AVForums Movies Podcast: Streaming Theatrical Releases And The Future Of Cinema
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom