• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Windows 10 - Public Network problem

WeegyAVLover

Distinguished Member
Hey All,

I have recently purchased a Lenovo Yoga2 tablet and upgraded from Windows 8.1 to 10 over the weekend. All worked fine and runs on my network with no problems.

The tablet is coming to work with me where my work provide a free wifi connection. I have previously used my iphone on this with no problems. However my windows10 tablet will not connect to the network.

Now I know the network is working as my phone connects to it as are other people who are using Macs and android phones.

When I try to connect to the network it asks me for security key. I enter this and then it SHOULD bring up a web page where I enter a username & password, however it does not bring up this page.

I am thinking this is a local problem with my tablet but I am not sure where to look. I have tried disabling defender and firewall completely but it has made no difference.

Any suggestions?

Thanks
Col
 

EndlessWaves

Distinguished Member
I wouldn't expect the wi-fi application to launch the browser on it's own. You'll probably need to open your browser and attempt to navigate to a page before it'll show up.

If it's not doing that then have you fiddled with your DNS settings? Usually these work by making the provided DNS servers redirect any address to the login page's IP until you put in the password. It should be set to acquire DNS from DHCP.
 

WeegyAVLover

Distinguished Member
Sorry for not responding sooner, its been a busy week.

Problem is that no one else is having this problem round about me and they are using various tech Windows 7/10 laptops or Macs, Ipads, Iphones, Android phones/tablets, etc. Its only me that has the issue.

Everyone else is connecting without issues so it must be something specific to my tablet Win10.

When I try and login it takes the Passkey for the network and tries to connect and either does not do anything after that (and does not connect) or displays a message "unable to connect to network" both scenarios result in no connection to the network.

So there are no DNS settings to change as there is no network present.

I am wondering if it is a setting I have missed or there is some sort of hardware/driver problem or incompatibility when trying to connect to the network.
 

EndlessWaves

Distinguished Member
It's a new enough device that I wouldn't expect incompatibility. I used to have a device that didn't like my wi-fi passphrase when it was all capitals but worked fine once I'd swapped the first letter to lower case so it could be a quirk like that, is changing the passphrase a possibility?

It might be worth checking the wi-fi driver version manually to make sure the Windows 10 auto-downloaded one is correct and up to date.
 

MacrosTheBlack

Well-known Member
Have you asked your IT guys at work about it? The fact you have to go to a webpage and enter a username and password after connecting to the Wifi is an unusual configuration. Normally it's just select Wifi network and enter a WPA or WPA2 password and you're on. So your work's free wifi must have some extra security that they can assist you with to get connected.
 

WeegyAVLover

Distinguished Member
changing any of the works wifi settings is not possible. they are a massive company. The page that comes up is fairly standard when connecting to a public network except my company want a user name & password. I also have the same thing happen when i connect to the free wifi on trams in Edinburgh, the only differences are the tram wifi just wants you to tick a button that you agree to their T's & C's. The other difference is i can connect to that wifi.

I have contacted my it helpdesk and they just say well if it does not work for you then it is your problem as it works for everyone else, its not a key system so they do not deal with it as a priority.
 

Har-One

Distinguished Member
As said by @EndlessWaves, Can you open a browser and ask you for the username and password?

You could also check that the browser is using redirection and cookies. Usually there is a message saying that the network requires further configuration. Do you get that message?

Another possible workaround is to type the address of the page manually in the browser. Have you tried different browsers?
 

The latest video from AVForums

Hisense U7H TV and T+A Solitaire T headphone reviews, AV/HiFi news plus, what is screen uniformity?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom