Question Why Isn’t My Denon AVR Decoding DTS?

housainim

Member
Background

I'm in the middle of upgrading my home theater setup, and am having some issues with audio decoding on my AVR.

For context, my TV, speakers, and laptop are connected to my AVR. I'm playing DTS and DTS-HD MA encoded movies on my laptop, its video is outputted to the TV, and its audio to the speakers (all via the AVR).
  • Samsung 85" Q80T QLED Smart 4K TV (2020)
  • Logitech Z906 5.1 Surround Sound Speaker System
  • Denon AVR-X1600H 7.2ch 4K AVR - Connected to the TV via HDMI eARC.
  • ThinkPad X1 Extreme Gen 2(Win 10 Pro, GTX 1650 MaxQ GPU - this is used by the HDMI port) - Connected to the AVR via HDMI.
    • I'm playing the movies on my laptop using VLC Media Player. Going to the codec information section while the movie is being played seems to reveal that the audio is recognised as DTS:

      1608547671814.png


    • Windows seems to recognise that the connected AVR supports DTS-encoded audio (among others):

      1608547720575.png
Note: I'll be using Plex Media Server and a device running a Plex Client to stream videos on my final setup (eg. Nvidia Shield TV Pro), but I've taken that out of the picture for troubleshooting purposes. The same issue mentioned below occurs when using Plex.

Issue

The AVR processes the audio using the DTS Neural:X protocol, instead of decoding it in DTS or DTS-HD MA.

1608547748017.png


Things I've Tried
  1. Going through the 'Movie' sound modes using my AVR's remote control - there is no option for DTS, DTS-HD, or DTS-HD MA. There are options for Stereo, Dolby Surround, Virtual and a few others.
  2. Going through the 'Pure' sound modes using my AVR's remote control - there are only two options: Auto and Direct. This is what I see when I choose Direct:

    1608547692601.png
Questions
  1. How can I confirm that my laptop is passing through DTS audio to the AVR via HDMI?
  2. Assuming my laptop is passing through DTS audio to the AVR, why does the AVR process the audio using the DTS Neural:X protocol instead of DTS (when the source file's audio is DTS-encoded)?
Thanks
 

Russ_64

Member

Jamie

Distinguished Member
Your PC isn't sending a bitstream to the receiver.

On the display posted above I've circled where it's indicating the receiver is receiving PCM audio.
IMG_20201221_134726.png

Can you bring up the information screen on the Denon that shows what audio you're getting. PCM could be just a 2 channel doenmix but equally it could be the PC is deciding the audio and sending multichannel audio to the amp.

Neural X processing is normally used to generate a surround sound effect from stereo so I think the first option is more likely though

I'm not on front of my PC right now but I think if you check the sound settings in VLC you should see a passthrough option which if ticked should resolve your issue.
 

ShanePJ

Well-known Member
AVForums Sponsor
I'd say its a VLC setting issue like @Jamie

Someone on the ALC forums has mentioned this could be whats wrong

Tools -> Preferences - Audio ->HDMI/SPDIF audio pass through - select 'Enabled', save and exit preferences

It could be you have already changed it, but since windows updates, it may have reset something loosing the setting along the way

I used have fun with Kodi reverting the sound which is why I moved to PowerDVD and since have never had an issue with the audio decoding. Version 20 Ultra removed the remote control feature from the phone where I asked for a refund and thus have stuck with version 19 Ultra :)
 

housainim

Member
Your PC isn't sending a bitstream to the receiver.

On the display posted above I've circled where it's indicating the receiver is receiving PCM audio.
View attachment 1426449
Can you bring up the information screen on the Denon that shows what audio you're getting. PCM could be just a 2 channel doenmix but equally it could be the PC is deciding the audio and sending multichannel audio to the amp.

Neural X processing is normally used to generate a surround sound effect from stereo so I think the first option is more likely though

I'm not on front of my PC right now but I think if you check the sound settings in VLC you should see a passthrough option which if ticked should resolve your issue.

This was indeed the issue, thank you! I enabled passthrough in VLC and I got the options for DTS HD MA and DTS HD on my AVR.

Thank you Russ and Shane for your help also, you were all on the right track.
 

The latest video from AVForums

Podcast: LG C1 OLED + JBL Synthesis SDR-35 First Thoughts, plus TV Show & Disc Reviews & more
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom