Why does my Denon 1507 sound worse than the TV sound?

Fisher

Active Member
I have just replaced all my AV equipment with:
Plasma: Panasonic TH37PX70
Sky HD (connected to the Denon with an optical cable)
DVD-R: Panasonic 25 (connected to the Denon with an optical cable)
Receiver: Denon 1507
Speakers: Mission M-Cube (connected to the Denon with QED cable)

I didn't get the speakers until a few days after the rest of the equipment so I had to use the sound from the plasma. This sounded pretty much as the TV it replaced. This weekend I have wired the Denon and everything seems to be working correctly but the sound is awful, it sounds like it's playing through a tin can. I have faffed around with the settings but can't see (or hear) what I'm doing wrong.

A few bit's of info that may help:
Speakers are set to small, the sub is on and is connected to the Denon with a single cable as recommended by Audio-T.
The room is an acoustic nightmare, laminate floor and bare painted walls. The only soft furnishings are the sofas.
I tried doing the auto setup but this failed everytime. I heard the test tone coming out of the correct speakers so I know they are all working and connected to the right terminals. I have increased the sound level of the centre as we always seem to have problems hearing the voices over the soundtrack.

As I said, the sound is very tinny and has no depth to it.

Any help would be greatly appreciated.

Regards

Fisher
 

[email protected]

Active Member
I am a newbie too and have just got the denon 1507 but with tannoy speakers. I have been tinkering and have sought advice on here as you will see from other threads. When i did the auto setup this worked ok and i have to say was a major improvement on my old argos Acoustic solutions system. Have you got your sub connected to the low level pre-out? Also what volume is your sub set too?

You say the auto setup did not work, do you mean it gave you an error message and did not finish or that it did finish but did not solve the problem?

Wolfy!!!
 

Fisher

Active Member
Wolfy

The sub is connected to the low level pre-out and the 'bass contour' (on the sub) is set to min, when I put it on max there doesn't seem to be any change in quality.

The auto setup showed an error message everytime I tried it saying no SL is connected.

Fisher
 

FunkyMonkey

Active Member
From the tinny sound and SL error, I woudl say your sub is nto doign anything. To confirm it is the sub, manually set teh speakers to large and see how it sounds. It should be pretty fullsome, but of course lackign the thud from the sub.

At least this will confrim the problem is your sub. Then go from there.
 

Fisher

Active Member
FunkMonkey

Tried that and there's no difference and when I've run the test tone I hear the sub.

Fisher
 

[email protected]

Active Member
Fisher,

When you run the test do you get a test tone from the SL (Surround Left) speaker?
Note too sure what the base contour is on your sub as i am not that experienced at all, my sub connects were labelled Low level.
Also when you do get a feed from your optical connectors does the amp quote the correct feed i.e Dolby/Dts?

Wolfy!!!!
 

rEVILospud

Well-known Member
Don't know if this helps, but the M-cube satellites have a frequency range starting from 280Hz and the Sub runs from 28Hz to 300Hz.
This means that you need your receiver's cross-over to be set to around 280-300Hz, as opposed the the normal 80Hz-ish for non-satellite style systems.

This means that all the way up to 280Hz only the sub is producing sound, which could contribute to the lack of depth of sound.
 

Fisher

Active Member
Thanks for the replies guy's.

Wolfy

I don't det a signal from the SL. The rear surround speakers are connected to teh SBL and SBR (which I presume is Surround Back Left and Right). Again, I presume SL stands for Surround Left.

The Receiver does quote the right sound source (DD or DTS, etc).


rEVILospud

I think I can only go up to 250Hz on the Denon. I'm now worried the Receiver won't work with these speakers.

Fisher
 

rEVILospud

Well-known Member
Are you able to turn off the crossover in the receiver?
It may be better to do that if you can and then just make sure they are all set to small.
 
A

alphabet

Guest
Maybe I am mistaken, but should you not rather connect the Surround-Left and Surround-Right speakers instead of Surround-back speakers if you use it in a 5.1 setup?

That is the way I understand it:D
 

rEVILospud

Well-known Member
I thought that too, but from his last post I believe Fisher is using 7.1
 

[email protected]

Active Member
The amp will detect if there is a speaker present, if using 5.1 set up the surrounds should be set to SL and SR not the back speakers. The back are to extend to 6.1 and 7.1 according to the manual.


Wolfy!
 
A

alphabet

Guest
The amp will detect if there is a speaker present, if using 5.1 set up the surrounds should be set to SL and SR not the back speakers. The back are to extend to 6.1 and 7.1 according to the manual.


Wolfy!

Sort of what I was aiming at yes
 

Fisher

Active Member
rEVILospud, alphabet and Wolfy

Once again, thanks for the replies.

I can't see anything in the menu's where I would be able to switch the Crossover off.

I have now set the speakers to 'small' (although the mission manual says they should be set to large).

I thought the SL and SR connections were if you are using 7.1 so I connected my rears to the SBL and SBR.

I am running 5.1 speakers.

The pic shows how I have connected the speakers and sub.

Fisher
 

Attachments

  • Denon Rear.jpg
    Denon Rear.jpg
    52.2 KB · Views: 894

[email protected]

Active Member
Fisher,

You need to move your surrounds over to the surround channel and not the back surround channel. I would have thought this may be a problem as the amp would only send the 6 and 7 part of the signal through to these speakers. If you are only listening to a 5.1 dolby or pro logic 2 signal they do not use the 6 and 7 speaker channels.
I am no expert though and am only using my logic on this one.

You are correct in that this amp does not appear to have a switch off for the cross over as i have looked though the settings, you can however set the cross over point and also set whether the low frequencies go to both the sub and satellites or just the sub.

Wolfy!!!!
 

Fisher

Active Member
Cheers Wolfy

I'll change the rears over and let you know how I get on.
I'll also try setting the low frequencies to sub only and then the sub and satellites to see which I prefer.

Fisher
 

Fisher

Active Member
Wolfy

I have now changed the rears to SL and SR. I re-did the auto set up again and all worked correctly, your logic is obviously better than mine:thumbsup:. I also tried the low frequencies to sub only and then the sub and satellites and I prefer the sub only option.

I got myself in such a tangle it was great to have the auto set up work and the system sound's a lot better. I'm sure it could be improved on but for now I'm more than happy. If an audiofile heard it they would probably cry but bear in mind I have gone from a NICAM TV to this combination and it sounds great to us which is all that matters in the end.

Thank's to you all (rEVILospud, FunkyMonkey, alphabet and Wolfy) I have been able to sort this out.

All I have to do now is find the SkyHD remote code for the Denon.

Cheers guy's

Fisher
 

The latest video from AVForums

Samsung QN95B 4K QLED TV Review
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom