Question Why do my nvidia TV blacks get blocky when watching through the amp, but not direct connection to TV

Lordsteggu

Novice Member
Hi,

This is my first time here and I have just purchased a new home theatre setup.

I have a few issues that seem to stem from the amp, but I'm not 100 sure.

Setup
yamaha rx-v581
Dali zensor 5
Dali vokal
Dali zensor 1
Panasonic tx-50cx680b
Nvidia TV

Here is my issue.

Before I got the setup my nvidia TV was connected directly to my TV via hdmi, now it goes through the amp.

The issue I am having is that the picture quality has gotten worse. Primarily the blacks, they are blocky and extremely prevalent. This only happens when viewing shows on the TV through the nvidia TV through the amp, direct hdmi to TV and the issue isn't there.

I'll add I watch shows both through Netflix and plex, the local files are 1080p dts, good quality.

I have attached two Images comparing the different connections, whilst I'm here is there anyway to get the better image smoother. Its still not perfect, I'm new to all this home theatre setup stuff.

Many thanks,

Daniel
 

Attachments

Violator

Well-known Member
Is the video set to pass through or straight on your AVR? because that's what it needs to be.
 

Lordsteggu

Novice Member
Hi,

The amp doesn't provide any upscaling, so it should be default passthrough / straight right?
The only straight I see on my AVR is for sound, and that just sets it to stereo sound basically.
 

mbmapit

Well-known Member
Check to see if going through your amp is changing any of the settings (compared to direct to TV) in the menu of the shield TV or inside Plex, it may be changing resolution, HDMI colour range etc. If not check page 104 in your manual which refers to setting the correct video output.
 

CARLOS

Distinguished Member
Have you tried any different HDMI cables as you are adding a 2nd one in the chain ?
 
Last edited:

Hixs

Distinguished Member
The amp is most likely adding extra processing.
 

CARLOS

Distinguished Member
The other thing to try is changing the HDMI mode to mode 1 in the advanced setup menu ?
 

KelvinS1965

Distinguished Member
As already said above the amp doesn't offer any video processing !
According to this Yamaha webpage it mentions on screen display (colour OSD) so this amp must do some video processing to achieve that. Given that I know my Marantz SR6010 can affect the image when the OSD is switched on, I would try turning it off to see if it makes any difference. Unfortunately some AVRs can't pass video without degrading it to some degree.
 

stevelup

Distinguished Member
Not necessarily - it's possible to insert an OSD into HDMI without doing any processing at all. Anthem do it for example.

But most stuff does!
 

KelvinS1965

Distinguished Member
I've heard that about Anthem, though I've never owned one myself. I bypass my AVR completely for my projector so the HDMI output of my Lumagen goes directly to the projector and the audio goes by a second HDMI output from the video processor.

This is also why I'm bemused when people ask about which AVR to buy for 'the best video processing/upscaling'. I don't know of any that are better than the average TV and (possibly) like the OP some that are worse...
 

CARLOS

Distinguished Member
I don't know of any that are better than the average TV and (possibly) like the OP some that are worse...
Who's saying its worse ? The OP hasn't yet found the cause and I still think its either a HDMI cable issue or more likely the amps HDMI mode needs changing to mode 1.
 

KelvinS1965

Distinguished Member
We'll have to see if the OP comes back and tries your idea. Sorry if you seem offended about my comments regarding AVR video processing, but I don't yet know of one that can beat a Lumagen...
 

CARLOS

Distinguished Member
We'll have to see if the OP comes back and tries your idea. Sorry if you seem offended about my comments regarding AVR video processing, but I don't yet know of one that can beat a Lumagen...
Not offended mate :) sorry if I sounded defensive its just in all my years I've never seen an amp have a negative effect on video passthrough.
 

KelvinS1965

Distinguished Member
Well they shouldn't on pass through, but I recall when I had an Onkyo 818 it was really involved to actually get it to that state (seemingly hidden menus and options). With my SR6010 I had set everything to bypass as far as I knew, but simply having the OSD engaged causes image degradation.

So perhaps my definition of pass through would be to have the OSD off as well (expect in the case of Anthem it seems). Even when there isn't any overlay (such as volume level) the degradation occurs with the SR6010/7010 apparently.
 

Hixs

Distinguished Member
Same with my 5010. A drive plugged straight into the tv has a better pic quality then when passed through AVR.
 

Trollslayer

Distinguished Member
Who's saying its worse ? The OP hasn't yet found the cause and I still think its either a HDMI cable issue or more likely the amps HDMI mode needs changing to mode 1.
If there was a cable issue it would show up as sparkles or complete loss of picture. HDMI is encrypted and there are data buffers in various devices (particularly the TV) so timing problems are pretty much eliminated.
 

Lordsteggu

Novice Member
Hi,

@mbmapit I have played around with the tv colour settings a bit and got the blacks less blocky, mainly turning the brightness down, I think it changed some settings when going through the amp, however it is still not perfect. It is a lot better, I have some spare cables will try them, it doesn't seem likely to be them though, I have had failed hdmi cables before and the screen breaks up rather than degrades.

I will have a look at the HDMI mode tonight and the on screen display, I need to check with the changes I made the other day back with the direct connection. Busy bank holiday weekend and all that.

Will give it another check tonight and compare the images again, thanks for all the information guys, will get back with more information soon.

Dan
 

stevelup

Distinguished Member
There is no point in changing any cables. HDMI either works or it doesn't.

I think I can predict what will happen when you go back to direct connection - you'll end up with an image that's too dark. Something somewhere is messing up the HDMI Colour Range. Your nVidia and your TV cannot agree between limited RGB (16-235) or full range (0-255), or possibly are negotiating component mode (YCbCr).

Do you have other sources connected via your AVR? And if so, are they working correctly. If they are, you should look again at the output settings on the nVidia.
 

Lordsteggu

Novice Member
Hi,

I think I have found the issue, it may be with the nvidia itself, I tried my ps4 through plex and the quality was much better, it was the same through direct and the av receiver itself.

In the hdmi settings of the nvidia shield tv it defaults to 4k 60hz full colour range and YCbCr, which should be fine as my tv hdmi supports deep colour and x.v.colour which support both rgb and YCbCr.

http://puu.sh/qUNMi/0d80b7a0e7.png

However if I lower the hdmi resolution on the nvidia down to 1080p the picture quality is instantly better, at this point there is then no massive difference between YCbCr or RGB. So my tv supports it as far as I could tell.

As soon as it is back in 4k resolution it is back to being terrible quality.

Both nvidia and tv are set on full range.

It seems to me that there is something wrong about the nvidias tv 4k support, that is all I can think of.

Cheers

Dan
 

The latest video from AVForums

Podcast: The Best TVs and Projectors of 2020, plus AV, TV Show & Movie News & Reviews

Latest News

What's new on Sky and NOW TV UK for December 2020
  • By Andy Bassett
  • Published
What's new on Netflix UK for December 2020
  • By Andy Bassett
  • Published
Warner Bros 2021 movies coming to HBO Max and cinemas simultaneously
  • By Andy Bassett
  • Published
What's new on Disney+ UK for December 2020
  • By Andy Bassett
  • Published
4K Streaming impacts carbon emissions says Royal Society
  • By Andy Bassett
  • Published
Top Bottom