'White spots' problem on Denon 1920 !

Discussion in 'Blu-ray & DVD Players & Recorders' started by Daipac, Mar 17, 2006.

  1. Daipac

    Daipac
    Active Member

    Joined:
    Apr 12, 2005
    Messages:
    659
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Ratings:
    +12
    My friend has recently bought the Denon 1920 and is connecting it to his Panasonic LCD via HDMI.

    A problem has occured where white spots appear every now and again on screen. He is now on his second 1920 which has just started doing the same thing.

    The store he bought it from have said they have the new firmware to put on the DVD player, but will this help solve this problem ?

    Anybody else had this problem before ? What is the cause ?

    Thanks for any help.

    D
     
  2. GreasyWeasel

    GreasyWeasel
    Active Member

    Joined:
    Aug 8, 2005
    Messages:
    355
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Shropshire
    Ratings:
    +13
    Your friend is coming round my house later today to test it out on my set up. Hopefully we'll get some were with it since I'm picking up my new 1920 today and I'd rather not have the same problem. :smashin:
     
  3. Daipac

    Daipac
    Active Member

    Joined:
    Apr 12, 2005
    Messages:
    659
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Ratings:
    +12
    LOL ! Nice one mate ! Let me know how you get on ! Catch ya on Live laters.

    D
     

Share This Page

Loading...