Dismiss Notice
Attention AVForums app / Tapatalk users
Sadly GDPR means that, from 25th, we can no longer offer access to AVForums via the branded app or Tapatalk.
Click here for more information.

whats wrong with this picture sony vpl-px30

Discussion in 'Projectors, Screens & Video Processors' started by gilbert100, Aug 9, 2005.

  1. gilbert100

    gilbert100
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have got a free Sony vpl-px30 that needs a new lamp (2750hrs) air filter cover and remote?
    It powers up and all the controls work. From the picture below any ideas as to the problem. Is it worth getting it fixed as the lamps cost about £400.any thoughts appreciated.
     

    Attached Files:

  2. NonPayingMember

    NonPayingMember
    Previously Liam @ Prog AV

    Joined:
    Oct 18, 2002
    Messages:
    8,523
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Kent
    Ratings:
    +830
    Could be on enormous blob of dust on one of the LCDs!!!!

    For £400 bulb, plus filter, plus Sony's extraordinary prices on replacement remotes I'd just get a new projector. Epson TW10h is budget champ, some cheap DLPs to be had too. Optoma H27, inFocus X2 etc.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice