1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What is wrong with spring clips?

Discussion in 'AV Receivers & Amplifiers' started by Vection, Jun 12, 2003.

  1. Vection

    Vection
    Standard Member

    Joined:
    Mar 23, 2002
    Messages:
    129
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    19
    Location:
    Over there!
    Ratings:
    +0
    As the title suggests really. I put my sisters technics midi/sperates thing together for her. It used spring clips on the amp and I found it sounded quite good.:rolleyes:

    Is there a technical reason the're frowned apon?
     
  2. TheBigApple

    TheBigApple
    Active Member

    Joined:
    Dec 10, 2002
    Messages:
    664
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    In my cage
    Ratings:
    +13
    I think it's to do with the size of cable you can fit in them.
     
  3. sounddog

    sounddog
    Well-known Member

    Joined:
    Dec 11, 2002
    Messages:
    3,416
    Products Owned:
    0
    Products Wanted:
    1
    Trophy Points:
    107
    Location:
    Leicestershire, UK
    Ratings:
    +474
    Agree monkeyboy ... can't get very big cable in ... and also they often don't make very positive connection.

    Vikki
     
  4. Hawklord

    Hawklord
    Well-known Member

    Joined:
    Feb 15, 2003
    Messages:
    3,518
    Products Owned:
    3
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Aldershot, Hampshire
    Ratings:
    +286
    It might be down to the contact surface area of the cable. The cable ends are also exposed to air and may oxidise/degrade quicker. The cable used is often fairly cheap and thin with midi systems so the signal being transmitted along it's length may not be as good as more expensive/thicker cable.
     
  5. Vection

    Vection
    Standard Member

    Joined:
    Mar 23, 2002
    Messages:
    129
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    19
    Location:
    Over there!
    Ratings:
    +0
    I take it that its nothing to do with the actual design then. only the poor quality materials associated with them.
     
  6. hamtaro

    hamtaro
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    spring clips are very poor for sqeezing cable in, mind you some binding posts are quite poor also........denon 1802 springs to mind!
     
  7. bob1

    bob1
    Well-known Member

    Joined:
    Nov 7, 2002
    Messages:
    4,354
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Sheffield
    Ratings:
    +131
    The post on the back of mine are poor,not a patch on the ones used on my old 930.
     

Share This Page

Loading...