1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What is up with my FarCry?

Discussion in 'PC Gaming & Rigs' started by janmars, Aug 19, 2005.

  1. janmars

    janmars
    Standard Member

    Joined:
    May 4, 2003
    Messages:
    162
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +2
    Just been playing on FarCry for the first time since I got my GF 6800. I haven't been playing a lot of games recently so I don't know if this affects other games. World of Warcraft works without any problems though.

    Anyway - the graphics in FarCry are all screwy regardless of what settings I set the game too.

    [​IMG]

    [​IMG]

    [​IMG]

    All the light areas are in bright white. The water in the game also has no reflections and is totally dull. The textures on the landscape and cars are also pretty poor.

    I have the most recent driver 77.77, I have also tried 77.72 drivers...

    Any idea what could be doing this?
     
  2. gargoyle

    gargoyle
    Active Member

    Joined:
    Nov 8, 2000
    Messages:
    629
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    birmingham
    Ratings:
    +21
    Which 6800 have you got? Is it overclocked?
     
  3. Kevin Gilmour

    Kevin Gilmour
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I had the same problem as this when I first got my 6600GT

    Now, I had quite a few problems with my card including having to get a replacement (use 3dMark05 to make sure the card isn't faulty) so not sure which one of these did the trick:

    It was either using OMEGA drivers (rather than NVid) or downloading the lastest patch for Farcry

    Hope this helps

    Kev
     
  4. Monkey Alan

    Monkey Alan
    Active Member

    Joined:
    Jan 19, 2005
    Messages:
    628
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Ratings:
    +39
    I had this problem when i got my 6800gt. Make sure you istall all the patchs for Far Cry right up to 1.33 I think it is.
     
  5. janmars

    janmars
    Standard Member

    Joined:
    May 4, 2003
    Messages:
    162
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +2
    Thanks - the patch fixed it!!
     

Share This Page

Loading...