Question What correct audio options do I set for KODI? Confused

Waynester

Active Member
Hi folks

I have a 5.1 home cinema setup
My AV amp is a Denon AVR-X2200W Amp

I’ve just installed latest version of KODI and in the system options in the audio setting on EXPERT mode, I don’t know whether to select 2.0 or 5.1 for my setup where it says “number of channels” I’m only using HDMI from my Amazon Fire TV box into my AV Receiver

I’ve allowed passthrough on these screenshots.... have I missed anything or what other settings would you recommend? I want to watch films in the best sound possible (obviously)

Getting conflicting information on an article I read here about HDMI settings (towards the bottom of the article)

it says to change number of channels to 5.1 and turn OFF “allow passthrough” 🤷🏻‍♂️🙄🤦‍♂️

 

Attachments

Last edited:

Waynester

Active Member
5.1. Allow pass through and enable all dts and dolby digital options.
nope, that doesn’t work

So when I “allowed passthrough” and selected 5.1 or even 7.1 on number of channels, the audio is only PCM on a Dolby dts digital movie.. look at the picture, it displays as MULTI IN on my AVR, this is not correct
 

Attachments

Waynester

Active Member
But when I change number of channels to 2.0 and allow passthrough I get Dolby perfectly on a movie

see picture here
 

Attachments

next010

Distinguished Member
The number of channels is PCM audio setting.

Pass-through setting is for Dolby/DTS formats.

These settings are in dire need of updating but it hasn't happened for years now and probably wont.

If your sound system supports PCM 5.1 or PCM 7.1 I would stick with that as its better for Kodi in terms of lip sync and decoding multichannel audio formats to PCM not supported by the sound system (or the FireTV OS).

So set number of channels to 7.1 and leave pass-through disabled that outputs everything as PCM up to 7.1 depending upon the source.
 

Waynester

Active Member
But I watch films on Kodi with decent audio like Dolby and DTS, why would I want PCM?
I don’t get any lip sync issues

Currently I’ve got passthrough ON and number of channels is 2.0, when that’s set I get Dolby etc

If I change that, you can see the difference on these images
 

Attachments

Frisbeepop

Active Member
I’m not sure the older fire box is helping the issue. As you don’t seem to be running atmos, as long as the stream is giving you 5.1 discrete channels, the quality level is relatively moot as all are lower resolution compared to DTS MA or dolby trueHD. They are all lossy.
I also suspect your kodi is old as there’s no DTS capable options showing

on my fire stick 4k, it plays everything with no issues on those settings
 

Waynester

Active Member
My KODI is the latest version 😳
I’m not running atmos as I don’t have it
 

The latest video from AVForums

LG CX 4K OLED TV Review: The best TV of 2020?
Top Bottom