1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wharfedale Diamond 8.3 - Base problem

Discussion in 'Home Cinema Speakers' started by allypolly, Jan 29, 2005.

  1. allypolly

    allypolly
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have had my diamond 8.3 speakers for 2 years now. The sound i get from them is has been amazing. Just recently one of speaker`s base driver has started to develop a crackling sound which has destroyed that perfect sound!! I guess that the base driver is broken due to my house mate playing it excessively loud!!

    What do I need to do to fix the problem. I have guessed that I`ll need to replace the base driver. They are 165mm kevlar cones. i have looked on the internet to find where i can buy one but i have had no luck.

    Could anyone help me with this and give me an idea of how much it would be.

    Cheers!
     
  2. CosmosD

    CosmosD
    Active Member

    Joined:
    Oct 28, 2004
    Messages:
    163
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Dover
    Ratings:
    +7
    Hi, sorry to hear your bad news. Try contacting Wharfedale's service department. http://www.wharfedale.co.uk/servspeak.htm
    I had a problem with a subwoofer a couple of years ago and they repaired it for me under warranty. They might be able to send you a new driver which should be fairly easy to replace if you or someone you know is handy with a soldering iron.
     
  3. allypolly

    allypolly
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks for your help. I will contact Wharfadale this week. Hopefully i`ll have them up and running to their former glory. Appreciate the help

    Cheers,

    Ally
     

Share This Page

Loading...