Weird PS4 Pro and Yamaha RX-V673 audio problem

flyblown

Novice Member
Hi, first post here so go easy on me.

I have a weird problem. When playing .FLAC files with Media Player on the PS4, when I am viewing the PS4 Media Player files/directories on the TV, the audio will only be output by the Yamaha AV receiver on the “Straight” program, such that only the two main front speakers and the subwoofer are working. If I try and select the normal 7.1 surround setting, it says “not available”.

As soon as I go out of Media Player on the PS4, to the home screen, which leaves the songs playing, the audio briefly switches off, then switches on but in full 7.1. All speakers working.

The PS4 is wired to the receiver by HDMI. Thing is, if I use the Toslink optical connection, it doesn’t do this, everything is fine. Whether Media Player is on screen or minimised, the sound is output as 7.1 surround. But the audio quality is markedly diminished to my ears at least, hence the desire to listen via HDMI.

Why on earth would having the app showing on the screen cause this default to “Straight”?

It’s a Playstation problem, because when I use the Sony UBP X-800 DVD / media player it plays 7.1 all the time. The reason I don’t like the Sony UBP is because the interface is clunky and drives me mad.

I am stumped and frustrated. If you have any idea, pls post, it would be much appreciated.

Cheers
Dave
 

The latest video from AVForums

Samsung S95B QD-OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom