Weird iTunes problem

Radiohead

Well-known Member
All of a sudden iTunes has decided to do the following:

a) Not play any of the music in the libary. It can see it all as usual, but when I select a track it won't actually start it. Nor will it play any of the tracks when the iPod is docked (although these all play fine on the iPod itself). The MP3's play fine in Media Player.

b) Not display any of the images within the iTunes Music Store, or playing any of the sample streams

I've uninstalled and reinstalled v6 and no joy. I've system restored back to last week when it worked ok and no joy.

The only new install on the PC is Motorola Mobile Tools with the V3 and I've both uninstalled and restored to past that, but again no joy.

Any ideas? It's doing my head in.
 

Radiohead

Well-known Member
I've resolved it now. For some reason there was a corrupt .dll buried deep within it. Did a full uninstall, cleared out the registry, and installed iTiunes and Quicktime separately (reaching this method after a couple of hours of trial and error). Seems to have worked. No idea what caused it.
 

DustySox

Active Member
Radiohead said:
I've resolved it now. For some reason there was a corrupt .dll buried deep within it. Did a full uninstall, cleared out the registry, and installed iTiunes and Quicktime separately (reaching this method after a couple of hours of trial and error). Seems to have worked. No idea what caused it.

Hi Radiohead,

I to have had problems with itunes. The only thing I didn't try was to clear out the registry. How would you do this?

atb

Darren
 

pjskel

Well-known Member
Run regedit under the start menu and search for Apple or iTunes, then remove them.
Alternatively there are many a utility to check the registry for orphans when you've removed software.
 

DustySox

Active Member
pjskel said:
Run regedit under the start menu and search for Apple or iTunes, then remove them.
Alternatively there are many a utility to check the registry for orphans when you've removed software.

Hi,

This has got me beat, and frustrated!

I have run "regedit", and deleted any Apple/itunes references. And still no joy. Is there anything else I can do? Itunes will not play any music in my library, or in the music store. I know all is ok, as Real player will play music in my itunes folder.

:lease: :lease: :lease:

Darren
 

pjskel

Well-known Member
There must be another file hiding somewhere that's corrupt. See if versiontracker has anything free/shareware-wise to look for orphaned files, etc. Run it and see what it pulls up.
Does the Windows version of iTunes have an unistall option when you run the installer? If so, re-install, reboot, then run the unistall option and see if that gets things back to an even keel. Then you should be able to reinstall once again and play your music.
Equally, have a look on the Apple Knowledge Base, or post the issue in the Discussions forums, and see if anyone has had a similar problem, and what they did to correct it.
 

DustySox

Active Member
Hi all....sorted.

Right click on itunes-
Properties-
Compatabilty-
Compatability mode-
No tick in the box, ie run in windows 95.

Disco!! It plays!

Fank gawd

I'm orf to bed, it's been a long day!!!!!!!!!!

atb

Darren
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom