Weird Canton DM50 issue, remote dies with 3D playback

mattressback

Active Member
Ok I've literally had a canton DM50 for an hour, just putting it through it's paces, came to play 3D blu ray via ps3 on panasonic tv, 42VT30 . PS3 Connected to tv via hdmi, tv to canton via supplied optical cable.

Sound plays fine through the box but as soon as the picture is in 3d the canton remote becomes completely unresponsive, no buttons work at all though sound still comes out of it. If I use tv remote to switch to 2D mode the remote instantly starts working again .

Any one experienced this?
 

av1 ash

Novice Member
Sounds like it will be an infrared issue. I'm sure that the 3d glasses on the VT30 sync using IR so this signal may be blocking the Cantons Remote.

How is it sounding so far? Looking at getting one at the end of the month.
 

mattressback

Active Member
Well I was just testing it so didn't actually have the 3D glasses on so can't be that lol. I've emailed canton but don't know if I'll get a reply. Everything else is working fine tho. Just had a game of battlefield 3 and really sounded impressive, planes flying overhead and bullets zipping by whereas on the other hand im found fifa13 sound to be a bit hollow , don't know why that is.

Music sounds great, action movies have ridiculously booming effects which can make you jump in you seat if they come in suddenly against quieter spoken scenes.

The grandprix qualifying sounded great today as well, I've watched a few tv shows and I'm trying to get used to slightly different sounding voices to what came rough my tv speakers. My tv speakers ain't bad, it's a panasonic vt30 series tv and the canton voices are slightly different, can't put my finger on how, not saying they are worse than the tv, just different.

Don't know if you saw my other post but I got richersounds to price match with Conrad electronic and they also applied a ten quid voucher Conrad were running so I got it delivered for £326 so can't complain at that price
 

av1 ash

Novice Member
I think the TV outputs an IR signal to find the 3d glasses but hopefully Canton will help.

Didn't see that - great price, if they still have it at that price at the end of the month then I will be one happy person!
 

mattressback

Active Member
Arr right I see, maybe that is it then, to be honest not a big issue, I probably watch about two 3d movies a year lol, I'll maybe dig the glasses out and try it with them activated, maybe that may make a difference, or not lol
 

mattressback

Active Member
Or maybe using my panasonic remote to control canton might make a difference. I'll remote back if I get round to setting it up lol
 

av1 ash

Novice Member
Good idea. Also if you want to turn off the VT30s speakers switch your TV into hotel mode and set the volumes at 0.
 

mattressback

Active Member
Aye I've looked into how to put the tv in hotel mode cheers. I still haven't actually got the canton under the tv yet, it's just on a wooden coffee table in front of the tv as I'm waiting for a mate to give me a hand on Monday. My only last worry is that it performs ok on my glass tv stand, that the glass doesn't have any adverse affect on performance , ie rattles or vibrates
 

mattressback

Active Member
Well I tried using my panasonic remote to control canton during 3D playback and that failed as well, same issue, canton speaker totally unresponsive so very strange, have emailed canton and had the reply

"is your tv a plasma?"

Obviously I'd told them what brand and model it was in the original question so not holding out much hope for a solution there lol
 

av1 ash

Novice Member
Hi, managed to pick this one up over the weekend.

I'm having major lip sync issues, did you have any? I've got a panasonic gt30 and cannot get it right via the lip sync function.

Really nice unit apart from this.
 

mattressback

Active Member
Hi, no lip sync issues at . How are you connected? I'm everything as it was previously connected to tv, that's ps3 to tv via hdmi and humax pvr to tv via scart and just optical from tv to canton
 

av1 ash

Novice Member
Had everything connected to TV via hdmi (ps3/4, humax pvr) and then optical from TV to Canton. Massively out of sync :S

Then tried going directly from Humax to Canton and has improved a little but still issues. Had the TV connected to the canton via analogue and it's worse, the issue I have is that the canton does not remember what sync levels are for each input so you have to adjust it everytime.

Do you think I have a faulty unit?
 

mattressback

Active Member
I've noticed on a couple of occasions the bass and treble settings have reset to 0 on my unit which is a tad annoying. I honestly can't say if you have a faulty unit. If it's well out of sync on a plain tv broadcast to canton then I'd suggest trying to get a replacement , if it's only out of sync on the other devices then it could be a conflict but I'm not knowledgable enough to know what
 

av1 ash

Novice Member
Had the replacement delivered today, no sync issues at all from any source, must of been a faulty unit.

Now to run it in and enjoy some great sound :)
 

The latest video from AVForums

Are the TCL MiniLED TVs better than OLED? TCL Interview with Marek Maciejewski | AVForums Podcast
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom