Web Interface v2.7 for Foxsat HDR

Partridge

Active Member
Dear all,

On behalf of adrianf36 and myself I'm pleased to announce the release of version 2.7 of the Web Interface for the Foxsat HDR.

This release includes improved error handling and updated user messages around the Web Interface EPG. It also includes updated and new Channel Icons (thanks to David500 and GaseousClay).

The major additional functionality is the ability to set manual timed record reservations from the web interface.

Combined with the channel editor plug-in for the web interface, this now also enables recordings to be scheduled for non-freesat channels, including those from other satellites.

The manual record reservation functionality is my first venture into modifying/developing code for the Foxsat HDR, and I'd like to offer my sincere thanks to adrianf36 for advice, help and corrections of my mistakes! I'd also like to express my thanks to the beta testing team of David500, edgeon, nowster, raydon and REPASSAC for their time and invaluable feedback.

Installation in the usual way - visit the Package Management page and click "Update package list from internet" then visit the "Upgrades" tab to install the new packages.

Detailed user documentation can be found in the usual place in the web-interface (start page, documentation link at the bottom). This includes a couple of important actions which are required to cater for the Foxsat's 3 am housekeeping process (the new web interface functionality does a few things which the Foxsat is not designed for, so it needs these setup actions for it to work seamlessly). So please read this documentation before posting questions back in this thread.

Hope you like it!

Update 1.6.2012: v2.71 now released, see post #20 below
Update 26.8.2012: v2.72 now released, see post #45 below
Update 19.10.2012: v2.73 now released, see post #59 below
.
 

Attachments

  • man_res_entry.png
    man_res_entry.png
    35.7 KB · Views: 685
Last edited:

dar2005

Active Member
Thanks guys for your continued excellent work on this interface, but for at least a week now I've been having problems updating the package list on the web interface. When I press "Update package list from Internet", the screen pops up saying "Processing request" and then this changes to "opkg update" as per the attached image. When I press "Close", there are no new items displayed under "upgrades".

Any ideas? My internet access is working fine. I'm using IE9 from my PC and have also tried via Safari on my iPad to no avail. The installed WebIf 2.62 is and has been working perfectly together with installed packages.

Thanks in advance
 

Attachments

  • FoxSatUpgrades.jpg
    FoxSatUpgrades.jpg
    61.8 KB · Views: 374

adrianf36

Well-known Member
Thanks guys for your continued excellent work on this interface, but for at least a week now I've been having problems updating the package list on the web interface. When I press "Update package list from Internet", the screen pops up saying "Processing request" and then this changes to "opkg update" as per the attached image. When I press "Close", there are no new items displayed under "upgrades".

Any ideas? My internet access is working fine. I'm using IE9 from my PC and have also tried via Safari on my iPad to no avail. The installed WebIf 2.62 is and has been working perfectly together with installed packages.

Thanks in advance
Are you able to try the following from a telnet prompt:
Code:
opkg update
That is the command that the web interface is running in the background. Perhaps the problem will be more obvious when run from telnet.
 

dar2005

Active Member
Are you able to try the following from a telnet prompt:
Code:
opkg update
That is the command that the web interface is running in the background. Perhaps the problem will be more obvious when run from telnet.

Thanks Adrian, I'll give that a try this evening. I only managed to install telnet and your excellent remote control 1.1 last week via the USB connection as I couldn't get the WebIf check for update to work.
 

dar2005

Active Member
Finally got a chance to enter the 'opkg update' command via telnet (see attached pic).

It would appear my HDR is not seeing the internet. I can only think this might be because I recently set the HDR to have a fixed IP address of 192.168.1.115. There must be something I've entered incorrectly on the HDR or else I need to set something within my router to enable internet access for this IP address,... but not sure. My router is a Linksys. Before setting the fixed IP address, updates for the web interface worked fine.

Any suggestions?
 

Attachments

  • Telnet_HDR.jpg
    Telnet_HDR.jpg
    49.3 KB · Views: 271

REPASSAC

Well-known Member
Finally got a chance to enter the 'opkg update' command via telnet (see attached pic).

It would appear my HDR is not seeing the internet. I can only think this might be because I recently set the HDR to have a fixed IP address of 192.168.1.115. There must be something I've entered incorrectly on the HDR or else I need to set something within my router to enable internet access for this IP address,... but not sure. My router is a Linksys. Before setting the fixed IP address, updates for the web interface worked fine.

Any suggestions?

Possibly a problem with the name server address?
Try entering nslookup google.com into a telnet session.
I would suggest you change back to using DHCP and achieve a static address by adding an address reservation for the HDR's MAC address. Most routers will not let you do that incorrectly.
 

onyx

Standard Member
Hi guys,

Just a quick word to say thanks for the update. :thumbsup:

Also, I mentioned previously in another thread that the DefAuthInit.sql doesn't contain an entry for ITV1 Wales (so can't set recordings for this channel), so I added it by hand. After the update it disappeared again, so any chance of getting it put in the next update?

Just needs the following line added near the bottom of DefAuthInit.sql (before "COMMIT"):
Code:
Update tbl_svc set aucDefaultAuthority='www.itv.com' where usSvcID='10020';

Thanks again.
 

raydon

Well-known Member
Hi guys,

Just a quick word to say thanks for the update. :thumbsup:

Also, I mentioned previously in another thread that the DefAuthInit.sql doesn't contain an entry for ITV1 Wales (so can't set recordings for this channel), so I added it by hand. After the update it disappeared again, so any chance of getting it put in the next update?
Thanks for the info onyx. Repository copy of DefAuthInit.sql now updated. Just use the 'Update package list from Internet' button on the web interface 'Package Management' page and this will update your local file.
 

raydon

Well-known Member
Just in case anyone is wondering, the VLC player Plug-in update now in the repository is just a very minor bugfix. No big deal, the initial volume level was being incorrectly displayed as 50% when it was actually 100%. Now fixed.
 

Blue Flame

Active Member
Hi,

Liking the manual timed recordings addition. Is it an option to consider having a button for this when you click on a programme on the seven day epg? (So that it will pick up all the details itself but still store as a manual setting).

My initial reasoning behind this was to allow me to record STV HD which has no option to record off the 7day epg anymore.
 

Partridge

Active Member
Liking the manual timed recordings addition. Is it an option to consider having a button for this when you click on a programme on the seven day epg? (So that it will pick up all the details itself but still store as a manual setting).
Hi Blue Flame - agree that this would be good for those channels sending freesat epg data but not (yet) formally in the freesat collection of channels, so not picked up by a freesat sat scan.

For the initial version (as a bit of a fix) the option to set recordings from the web-interface has just been disabled for such channels (since as per our testing together the HDR unfortunately didn't handle the channel data properly for channels > 5000).

It is on the to-do list for future updates, however first priority is the functionality to be able to edit manually set recordings (in beta test at the moment). Bit tight for time at the moment I'm afraid as are a couple of the others involved in development...
 

Blue Flame

Active Member
:thumbsup: Thanks for the reply. Good to know it's on the to-do list.

It might be useful, even, for native freesat channels. F1 for example to cut off the first hour of the build up !! (It does run the risk of losing the end of the race though if there is a delay pre or mid race)

Many thanks again
 

caldirun

Member
I have experienced problems with file and EPG title renaming, I find I can rename 6 programs then Mongoose stops running (and the 7th program shows only the file to rename not the EPG title and this file will not rename anyway as Mongoose has stopped). I have experienced this the last 2 times I have tried to rename a list of episodes in a series folder, can this bug be addressed easily? or do we have to telnet and restart Mongoose each time? thanks, John
I must add that these are programs converted with AV2HDR if this has any relevance.
 
Last edited:

stapldm

Standard Member
Another serviceID to add to the mix please; found this for ITV Meridian South:

Code:
{serviceid 10140 eventid 16293 starttime 1338753600 duration 7200 encrypted 0 name Vera descr {Sandancers: Vera and the team investigate a murder at an army barracks. Sensing a connection to a death in Afghanistan, Vera uncovers the hidden trauma behind the crime. [AD,S]} warning {This programme contains  scenes which viewers may find distressing, acts of violence and strong language.} contentcode 15 contenttype Drama ECRID /658297678 SCRID /1273810042 RCRID {} usLcn 103 szSvcName {ITV1 Mer South} aucDefaultAuthority www.itv.com hSvc 0 Magic 1014}

I've added it to mine manually already, but if it could be updated into the package that would be great.

Thanks once again for this epic product and the legendary support and development efforts you give so generously :smashin:
 

REPASSAC

Well-known Member
I have experienced problems with file and EPG title renaming, I find I can rename 6 programs then Mongoose stops running (and the 7th program shows only the file to rename not the EPG title and this file will not rename anyway as Mongoose has stopped). I have experienced this the last 2 times I have tried to rename a list of episodes in a series folder, can this bug be addressed easily? or do we have to telnet and restart Mongoose each time? thanks, John
I must add that these are programs converted with AV2HDR if this has any relevance.

The problem is with mongoose and seems to be associated with browser activity while it is processing - other than that the cause has not been tracked down. mongoose is Google's open source with some custom fixes to get it running on the Foxsat.
 

raydon

Well-known Member
Another serviceID to add to the mix please; found this for ITV Meridian South:

I've added it to mine manually already, but if it could be updated into the package that would be great.
Thanks, DefAuthInit.sql now updated.
Code:
Update tbl_svc set aucDefaultAuthority='www.itv.com' where usSvcID='10140';
 

REPASSAC

Well-known Member
I have experienced problems with file and EPG title renaming, I find I can rename 6 programs then Mongoose stops running (and the 7th program shows only the file to rename not the EPG title and this file will not rename anyway as Mongoose has stopped). I have experienced this the last 2 times I have tried to rename a list of episodes in a series folder, can this bug be addressed easily? or do we have to telnet and restart Mongoose each time? thanks, John
I must add that these are programs converted with AV2HDR if this has any relevance.


The versions of mongoose that run on the T2 and Foxsat are identical (except for one string). To date no problems have been reported on the T2. We think that on the Foxsat it it just a matter of processor power - sometimes it cannot cope.

Adrian is going to try and replicate your problem - however it may be down to what else was going on at the time on your Foxsat.
 

Partridge

Active Member
Dear all,

On behalf of adrianf36 and myself I'm pleased to announce that v2.71 of the web interface is now in the repository; installation in the usual way.

This release adds the following functionality to the "Scheduled Events" page:

  • Editing manual record reservations (via new "more" button for each reservation)
  • Changing the target folder for EPG series recordings (also via the "more" button")
  • Direct access to upcoming event EPG details by clicking the entries in the column "Next Events"
Plus some tidying up of alert and prompt boxes for more consistent look and feel, additional channel icons etc.

Thanks to af123 for kindly consenting to porting of code from the Humax Fox T2 web interface.

Thanks to the beta testers: edgeon, David500, raydon, REPASSAC.
 

GaseousClay

Member
Hi Partridge. :hiya:

On the pop out from the more button I'm getting two options, 'Search' and 'Rename Folder' overlapping each other. When I mouseover the 'EPG Series' field it then just shows 'Rename Folder'.

Great stuff though. :thumbsup:

Running firefox version 12.0
 
Last edited:

Partridge

Active Member
On the pop out from the more button I'm getting two options, 'Search' and 'Rename Folder' overlapping each other. When I mouseover the 'EPG Series' field it then just shows 'Rename Folder'.
Hi GC, that's odd - the options should be "EPG Series Search" and then "Rename Folder" on the next line of the context menu.

For some reason your browser is wrapping the EPG Series Search line into the next line. Also it's not showing the icons in the context menu (see thumbnail below).

The new stuff was tested on a few browsers (incl. FF 12 on a couple of platforms) and I haven't seen this before. Javascript must be active since the context menu is being shown. Does it make any difference if you use a different browser (to see whether it is browser-related or HDR installation-related)?

I'm struggling to think of ideas here. Anyone else with this problem to try and help narrow it down (or anyone else with a bright idea)?
 

Attachments

  • context.png
    context.png
    7.3 KB · Views: 168

GaseousClay

Member
Ok, IE renders it fine but I notice Safari on my ipod doesn't. It's not really a big deal I was just concerned that I might have been missing out on one of the options. :D

Thanks for responding Partridge. :smashin:
 

grahamlthompson

In memoriam
Can't wait to try this out :D, in Prague at the moment.
 

The latest video from AVForums

Samsung QN800B 8K TV Review
Subscribe to our YouTube channel

Latest News

Movies Podcast: 8th August 2022
  • By Casimir Harlow
  • Published
AVForums Podcast: 8th August 2022
  • By Phil Hinton
  • Published
Warner Bros Discovery set to combine Discovery+ and HBO Max
  • By Ian Collen
  • Published
What's new on Sky, NOW and Paramount+ UK for September 2022
  • By Andy Bassett
  • Published
Pro-Ject Audio launches X2 B turntable
  • By Ian Collen
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom