WDTV Live Plus TrueHD Problem

speighty

Novice Member
My dad has just purchased the new wdtv live plus, i have connected it to a yamaha ysp-2200 soundbar via hdmi, my problem is that i cannot get dolby truehd.

I have changed the audio settings in the wdtv to send the audio digitally via hdmi.

I can get dts and dolby digital but when a film has truehd it comes up saying no signal.

All my films are in m2ts format, as far as i know this is the only format that will allow truehd to work.

I have tried the films at my house on a wdtv live and my amp is playing the truehd audio fine.

Could it be the settings on the soundbar, surely it should detect the truehd signal.
 

andy1249

Distinguished Member
Its not mentioned on the list of compatible audio codecs here ,

WD TV Live Plus

As far as I know , none of the WDTV models support the newer HD audio codecs , although mine is last years model so not 100% sure of the newer models.
 

next010

Distinguished Member
The WDTV Live's support TrueHD pass-through but not DTS-MA.

Could be the WDTV is expecting the TrueHD to be in an MKV container, try ripping a Blu-ray with MakeMKV taking the TrueHD audio track and see if it works.

If it still doesn't then it may be a compatibility issue with the Yamaha amp.
 

KevG123

Novice Member
All my mkv's with TrueHD work on a WD Live TV Hub so you should be ok
 

andy1249

Distinguished Member
I have the live hub myself , and while an MKV with Tru HD or DTS MA do indeed work , they are not passing on the lossless codecs to the amp ,rather they are extracting the lossy codec , in the case of Tru HD that would be AC3 and in the case of DTS MA that would be core DTS.

It does not pass on the HD codecs to the amp , my amp reports exactly what its getting , so Im positive about this.
 

KevG123

Novice Member
I have the live hub myself , and while an MKV with Tru HD or DTS MA do indeed work , they are not passing on the lossless codecs to the amp ,rather they are extracting the lossy codec , in the case of Tru HD that would be AC3 and in the case of DTS MA that would be core DTS.

It does not pass on the HD codecs to the amp , my amp reports exactly what its getting , so Im positive about this.

I have the ONKYO 609 and it displays the TrueHD logo so I'm assuming it works
 

The latest video from AVForums

Podcast: Trinnov Room Optimiser: A full explanation of Trinnov and its room optimiser technology
Support AVForums with Patreon

Top Bottom