WDTV Live corrupting my files!!!

drunken_prozac

Active Member
Hi All,

I have had my WDTV Live for well over a year now, maybe even two and had no issues until now.
A few weeks back I upgraded the firmware to the latest one avaliable, now it seems to have corrupted some of my files.

What happens;
I pick a file from my list (MKV/AVI/MP4) and it starts playing, all is well and I enjoy the program/movie.

About 3/4 of the way through the player stops and takes me back to the main menu.

If I go back to the file and press play it restarts from the begining (no option to resume) but I am now unable to fastforward the file.

If I press fast forward a few times a error comes up saying "this file does not support trick mode"

If I now take the file and play it in any other player it will not let me fast forward OR if I play through a PC, Windows media player wont play it at all, and other players (GOM/VLC) load 75% of the file and wont load any more.



This is from a USB stick, a network drive, a stand alone usb powered HDD and a mains powered USB drive.

This has happened with a 700mb avi with stereo mp3 audio, a 9GB MKV with 5.1 ac3 audio, an 8GB MKV with 5.1 DTS audio and a 300mb avi.

All these files are different and played before fine, now all of them are corrupt.


Anyone else got this problem? Is there a fix? and is there a way to fix my files????

any help very very welcome :eek:)

thanks

Darren
 

next010

Distinguished Member
It sounds like the WDTV Live is defective, to do that sort of damage corrupting the source video is extremely rare. It sounds like what's happening is the index is being corrupted on the video, this is basically what tells the media player the length of the video and allows you to fast forward/rewind/seek (trick mode) through the video.

If you set read only permissions on the network share does it still happen but not corrupt the files as there should be no way for it to damage the video without write permissions.

If you Google WDTV trick mode you will see people with similar problems to yours (but no solutions offered), I suspect the unit is defective given the different platforms you have tested so it's not the storage. Repairing the damage done to the media isn't so easy, you can try remuxing using MKVmerge and it might be able to restore the index on the video.
 

drunken_prozac

Active Member
thanks for the reply,

Yes this sounds exactly liek the issue, if I try to open the defective file through VLC it tells me the avi is broken, and asks if I want to fix it. If I say yes, it gets to 74% and then stops.

Most of the files I ripped from my DVD collection so its not too much of a problem to rip them back off just annoying and only since the software update.

I might try rolling back to a previous version and seeing if the problem persists.

As for setting to read only on the network drive, I mainly use my powered USB drive and it doesn't seem to corrupt every file, just when it feels like it.


I will email WD and ask them if they have a fix.

thanks for your help

Darren
 

drunken_prozac

Active Member
Just in case anyone is interested I have emailed WD and they are looking into why this has happened.

I rolled back the software to 1.05.04 last night and watched 4 files, all seem fine and the loading of drives is much much faster than with the newer software.

I will keep this thread updated in case there is an issue when WD get back to me

:eek:)

Darren
 

kaischroder

Standard Member
I have exactly the same issue, some files (and I got it to happen two times on the same file after copying it back to the same location) gets changed to 0-bytes. I also managed to get one to play for about 2 minutes and then crash, and after that this file was around 150Mb...

latest software version installed, files works great on other players...
 

drunken_prozac

Active Member
kaischroder, I am still waiting for the WD tech guys to get back to me (xmas break) but i downgraded to 1.05.04 last week and everything is still running fine, if not better than before as all my attached bee's seem to load faster.

I would try it.

Download this-> http://download.wdc.com/wdtv/Rollback_wdtvlive_release_1.05.04_V.zip

Then extract the three files (.BIN, .VER, and .FFF files) to the root (top level) of a portable USB drive

Unplug the WDTV from the network (just in case) and start it up. It should tell you new firmware is found. The numbers might seem off (i.e. version 2.5) but this is just so the WDTV can see its newer than its current version.

Install and it will reboot :)

Only issue I have is that once back on the network the WDTV tells me 'new firmware available' on boot as i have the older version now installed. I just ignore it until I hear back from the WD tech guys.

Hope this helps
Darren
 

drunken_prozac

Active Member
Ok,

After a few emails back and forth I have been told "we don't have a firmware fix"

I am still running on the previous firmware version and all is working fine but the player is always asking me to update it as there isa newer version of firmware available (the broken one).

I have tried to ask the helpdesk if they could look into the issue and if they had any idea if they were going to pull the firmware as more people are having the issue but no reply.

Looks like there is an issue but no-one wants to admit it :-(

Darren
 

kaischroder

Standard Member
Hi,

my case is now at "back-office" support, and they asked about which file system I used. I've tried both MAC OS EXTENDED, journaled and not journaled, as well as NTFS, what are you guys on?

I've given up and intend to return the device as soon as possible. I can't use it since I don't know which file it will corrupt next. going for a net top with xbmc instead I guess.

// Kai
 

The latest video from AVForums

Podcast: Samsung TV Launch & QN95A Neo QLED Review, plus Film & TV news & Reviews
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom