W7 MC .mkv troubles

Discussion in 'Home Entertainment Computers' started by Ian North, Jan 9, 2012.

  1. Ian North

    Ian North
    Standard Member

    Joined:
    Nov 26, 2011
    Messages:
    50
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Location:
    Poitou-Charentes
    Ratings:
    +2
    The more of the aged material I read the more I am confused. I have an x64 W7 install and am happy to use the MS decoders for the low res avi files, they look fine. I am trying to get 1080 .mkv files to play. 720 plays OK even though graphstudio shows DTV-DVD in use. The machine is plenty powerful, never gets above 1 or 2% on xvid, about 3% on DVD (2120T, 8Gb ram). I have been using a Lenny T61 as a testbed which is not ideal as the graphics are pre DXVA and I will want to use DXVA if poss because I have a 1Gb DDR3 6570 GPU.
    Installed late 2011 build ffdshow x64 and haali 1.9.63.13, tried the gabest and had no fun on the laptop. Audio tray icon shows as does haali icon but no ffdshow video. I ran graphstudio and DTV-DVD is placed, no sign of haali though the systray icon shows. I have to tread careful because I have a tuner card installed.
    In short I will let 7MC handle MS own and divx/xvid, not to break HD live TV and be able to play 1080 .mkv. Tried disabling x64 DTV-DVD using 7DS tweaker to no avail. Any pointers or guidance would be appreciated. No I havent tried the shark codec packs, my 9 yr old s478 now worth 10 bob gallatin chip and 7600gs card does 1080p .mkv at 30% CPU and no hardware accel, albeit at 32 bit but no codec pack. MS have made the job difficult for the hard of thinking like myself.
    I should of course add that 1080 files are opened in MC and seen in the library but fart and stutter and intermittantly pixelatem not a very satisfying experience.
     
    Last edited: Jan 9, 2012
  2. mitch1

    mitch1
    Active Member

    Joined:
    Feb 2, 2010
    Messages:
    160
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +13
    Is there a reason you haven't used sharks pack. Id say this would solve your problems with minimal hassle. Be sure to install both 32 and 64
     
  3. Ian North

    Ian North
    Standard Member

    Joined:
    Nov 26, 2011
    Messages:
    50
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Location:
    Poitou-Charentes
    Ratings:
    +2
    Just pig headedness really. That I have 1080 mkv`s playing on a steam powered x86 machine without so much as installing ffdshow and a well old version of Haali splitter tells me I can do the same with a current all singing and dancing machine. I did not reckon with media foundation and perhaps a poorly constructed splitter. I put my money on me not understanding MS media foundation and the use of W7 DS filtertweaker but i am unsure because fault finding AV decoder setup is uncharted territory. Especially for x64 machines. I don`t use system restore normally but I have created a large disc alllotment and created a restore point so i can dabble. The install on the 2120T machine is very clean W7 SP1 with nought more than edimax wi-fi and Blackgolds dicky drivers plus a recent ffdshow x64 build and Haali. I read that sometimes graphstudio does not tell the whole story. Haali icon shows but graphstudio tells me it aint in use.
     
  4. icstm

    icstm
    Active Member

    Joined:
    Sep 24, 2007
    Messages:
    1,212
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Ratings:
    +66
    I have used W7 DS filtertweaker and shark007.
    When I used the former, I used mpc-ht standalone filters for mkv playback (both mkv splitter and 264 codec support) You have to load both 32 and 64 bit splitters and codec.
     
  5. djcla

    djcla
    Well-known Member

    Joined:
    Nov 27, 2005
    Messages:
    7,435
    Products Owned:
    3
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Gloucestershire
    Ratings:
    +528
    U tried removing everything ffdshow, haali etc and just run lav splitter and audio decoder?
     
  6. djcla

    djcla
    Well-known Member

    Joined:
    Nov 27, 2005
    Messages:
    7,435
    Products Owned:
    3
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Gloucestershire
    Ratings:
    +528
    After removing everything use win7dsfilter tweeker and make sure everything reset to ms
     
  7. Ian North

    Ian North
    Standard Member

    Joined:
    Nov 26, 2011
    Messages:
    50
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Location:
    Poitou-Charentes
    Ratings:
    +2
    Read my mind. I had considered using LAV splitter as an alternative to ffdshow/haali. Mainly because I only require none MS native for .MKV. I will uninstall ffdshow and Haali splitter and roll back to saved restore to be sure then give LAV a try. Am I correct to assume that I will not have DXVA with this method or does MS H264 deal with that?
     
  8. djcla

    djcla
    Well-known Member

    Joined:
    Nov 27, 2005
    Messages:
    7,435
    Products Owned:
    3
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Gloucestershire
    Ratings:
    +528
    Lav splitter will work with win7 ms decoders which are dxva2 . Just don't tick lav video during install I only use audio and the splitter. You will need to configure lav audio
     
  9. Ian North

    Ian North
    Standard Member

    Joined:
    Nov 26, 2011
    Messages:
    50
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Location:
    Poitou-Charentes
    Ratings:
    +2
    Before I junk the Haali splitter I am tinkering with ffdshow and ds filter tweaker. I ticked VC1 this try, disabled DTV-DVD. Now when I play the 720 files 3 icons show, DXVA, ffdshow audio and Haali. DXVA does not display Info&CPU data, ffdshow audio shows correct looking Info&CPU data, Haali shows V and A graph and corresponding frame/ bitrate data. CPU in task mngr shows about 2% when playing 720.
    I downloaded a couple of 1080 .mkv sample files and again all 3 icons show and the picture is perfect. The offending 1080 files are TV caps, one of them a Louis Stevenson story with Eddie Izzard, very recent, about 3GB plus per part ; )
    Are there any sample files that you gents use as yardsticks for your builds? Do I need to find a tool to show me what is different with these troublesome files?

    Bear in mind that the offending files play very nicely on the 32 bit s478 steam powered edition.
     
    Last edited: Jan 12, 2012
  10. Ian North

    Ian North
    Standard Member

    Joined:
    Nov 26, 2011
    Messages:
    50
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Location:
    Poitou-Charentes
    Ratings:
    +2
    I searched for some mkv samples, various 1080p, they all played, without fault or complaint and quite perfectly. Next I searched for some sample files with huge bitrate, they all played perfectly too. One of them, don`t know if its a legal sample so will only mention it has digital animation came in at 16Mb/s, it too plays perfectly. Haali graph shows average of 16, peak of 24Mb/s. DXVA is very likely working as CPU load shows average 6%.
    For a moment I thought maybe the TV cap that won`t play is borked, then I remembered it does play perfectly on an x86 machine. It goes to show that I have much to learn in the world of AV before I get a reliable machine setup.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice