VT50 no longer displaying bluray player

Discussion in 'Plasma TVs Forum' started by Monkeyboy83, Oct 1, 2016.

  1. Monkeyboy83

    Monkeyboy83
    Novice Member

    Joined:
    Oct 1, 2016
    Messages:
    10
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Location:
    Cardiff
    Ratings:
    +3
    Hopefully someone will know what has gone wrong.

    I currently have a Panasonic55VT50 connected to a Panasonic BTT590 home cinema system. I turned the BR player on today but nothing was displayed on the tv, I thought weird so switched it off at the wall and back on but still no picture just sound from the surround sound speakers. I have tried 5 different HDMI cables, tried all 4HDMI ports on the tv but nothing works, I have even connected my sky box to the bluray HMDI port and it worked fine. What is really confusing me is I took the bluray player upstairs to try on my 10year old Panasonic tv and it displayed the bluray fine. So I went back downstairs and still nothing, it won't even play sound through the tv if I disconnect the surround sound speakers which it did upstairs. I have reset the settings on both the tv and BR player but no joy. My guess is one of my kids has changed something which I cannot figure out.

    Thanks in advance for any solutions.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice