VSX LX55 - HDCP error unless both TV and Projector powered on??

pioneerhifi

Standard Member
Both my TV and projector are connected the Pioneer by HDMI, but the only way I can watch a movie on my projector is to disconnect the HDMI cable from the TV. If both are connected but one isn't turned on I get a HDCP error, it's fine if both are turned on but that's a ridiculous scenario. Any help much appreciated, I'm new to home Cinema so still learning.
 

Lee.Pie

Active Member
I get the same with mine unless I use the hdmi out button to switch to the appropriate hdmi out for the device I'm using. ie hdmi 1 for TV and hdmi 2 for projector so don't use the hdmi all function. I have set my Harmony remote to do this automaticity so I don't have to worry about it.
 

Mark.Yudkin

Distinguished Member
Both my TV and projector are connected the Pioneer by HDMI, but the only way I can watch a movie on my projector is to disconnect the HDMI cable from the TV. If both are connected but one isn't turned on I get a HDCP error, it's fine if both are turned on but that's a ridiculous scenario. Any help much appreciated, I'm new to home Cinema so still learning.
I assume you're using some form of standby, rather then actually having the TV and projector off. What happens if the TV or projector is disconnected fro the power supply?

Your unidentified TV and projector may have a "power savings" standby mode which disables the HDMI processsing, thus preventing them from responding to the HDCP handshake. Check the manuals for the TV and projector to see if this is the case.

The power savings option may be implied by the general "HDMI Control" option; in such a case, you just need to turn it on. The specific name of that option is manufacturer-dependent (e.g. your Pioneer calls it Kuro Link), so you'll need to find the actual name from the manuals' descriptions.
 

pioneerhifi

Standard Member
Thanks for the advice Lee, will look into HDMI out for separate devices, I don't have the harmony though, just use the AV2 iPad app (the AV is in also different room to keep my installation tidy).

Mark thanks for your advice, it doesn't seem to matter which combination I activate the devices to handshake, the only way I can get rid of the HDCP error is to have all my devices on at once or physically disconnect the HDMI cable for that item I don't want on. No wonder people buy strippers (HDMI of course lol), my projector is the the 3D Panny, the TV is a Smart Samsung, so both pretty modern, just seems like I'm falling foul of HDMI Bullsh*t. I have the HDMI options set to talk to the devices and the same with the TV etc. Any advice or thoughts very welcome, cheers.
 

pioneerhifi

Standard Member
UPDATE: The HDMI 'all function has' one other option - PQLS, activated this but still HDCP error.... Very confusing...
 

Lee.Pie

Active Member
Unfortunately you can't change the HDMI out setting on the ipad app, only works on the remote and i think also there may be a button the the amp itself. I'm at work at the mo so can't check. It's the only way i could watch my projector was with just HDMI out 2 active or i'd get the NDCP error.
 

pioneerhifi

Standard Member
Cheers Lee, don't suppose you have a couple of basic instructions so I can copy your configuration, that would help immensely. The Amp itself is superb, surprised Pioneer didn't anticipate this, never had it on my Onkyo...
 

pioneerhifi

Standard Member
Hi Lee, I've been playing around with this but don't seem to be able to get it working, just wondered what, combination of settings you have used to allow HDMI out 2 active, by the way I have the same projector as you.

Cheers for any help.
 

cossie

Active Member
Lee.Pie

I believe your problem is because like me you have a 3D display, projector, and a non 3D display, TV, connected at the same time. The receiver will default to what it sees as the lowest common level in each to enable it to display the same picture on both displays irrespective of the type of picture, 2D or 3D, being transmitted. That's why you have to switch off the HDMI output to the TV when you want to use the projector in 3D mode.

This is a common problem with HDMI switches, which the receiver has. It can be overcome with an HDMI matrix but they cost lots more money.
 

pioneerhifi

Standard Member
Thanks Lee, that makes sense now. How did you switch off the HDMI output to the TV (at the moment I just have to unplug the HDMI cable form the back of which is a joke), I know how to configure the inputs using the settings, but have struggled to find the output configuration. Any help appreciated. Cheers...
 

Lee.Pie

Active Member
Sorry Pioneerhifi for the late reply.

I never originally had a problem with mine unless i watched something in 3D on my projector (as Cossie states), to which i had to change the HDMI Out to OUT 2.

But ever since Panasonic did the firmware update to my projector i've had to set my amp to OUT 2 for all use on my projector, 2D or 3D otherwise i'd get the HDCP error.

To change the HDMI OUT function to whatever you projector is plugged into:



Keep pressing the highlighted button until it shows HDMI OUT 2 (presuming you are using out 2) on the amps display. There is a delay between button presses where it will say 'please wait' on the display so just wait for that to go before you press it again.

Give it ago and let me know how you get on.
I'm off work tomorrow so can have a better look then if needs be.
 

pioneerhifi

Standard Member
Brilliant, works, Cheers mate.

Shame there's not a way to have HDMI out to both with one off, but this is still much better, thanks for the help Lee.
 

Lee.Pie

Active Member
No worries, Glad it worked.

Yeah it is annoying you cant just leave it on both. Like I say though it used to work fine before the Projector update.
Strange.
 

Andrew Cheung

Novice Member
Guys....I know it's an old thread but it just can't stop me replying it with my appreciation....I got a similar setup (one projector + one TV) except both of them are just 2D guys......it was so annoying when it came up...sometimes, but not always. Now it's gone with the HDMI Out function. Thank you so much!!!

P.S.: The lesson learnt was that I shouldn't be too lazy to read user manuals.....what a painful lesson!
 

The latest video from AVForums

Podcast: Reported HDMI 2.1 bugs, Audiolab Amp & LG LED Projector reviews + Best of the Month
Top Bottom