VMC internal audio codec problems

Discussion in 'Home Entertainment Computers' started by LoneGroover, Feb 1, 2009.

  1. LoneGroover

    LoneGroover
    Standard Member

    Joined:
    Aug 14, 2006
    Messages:
    18
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    3
    Location:
    Guildford
    Ratings:
    +1
    Hi, I've got VMC with the TV pack installed, and everything works fine except multi-channel audio from DVDs. The only audio out is through a SPDIF taken off the onboard audio (realtek). This works fine when I play DVDs through PowerDVD or WMP, but if I try DVD playback through WMC it's not 5:1 (presumably mixed down to stereo). I can even play back AVIs with 5:1 sound from VMC and this works OK (this uses AC3 though, which VMC doesn't seem to do for DVDs).
    If I go through the VMC audio setup & select 5:1, then the sound test only plays through the front speakers. I don't get any other options available.
    I have AC3, FFDShow & PowerDVD7 installed, no other codecs.
    It appears that the DVD audio is using some kind of internal VMC codec, but I can't find anyway to change the settings on this.
    I've tried re-installing drivers & various codec settings, but to no avail. Can anyone throw any light on this?
     
  2. LoneGroover

    LoneGroover
    Standard Member

    Joined:
    Aug 14, 2006
    Messages:
    18
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    3
    Location:
    Guildford
    Ratings:
    +1
    Fixed it at last. After two weeks of faffing about I saw a post on a TV-Pack bug track which mentioned that enabling volume levelling forced the audio to stereo out. A quick check showed I had the volume levelling enabled, once I disabled it I had 5:1 from my DVDs again :)
     

Share This Page

Loading...