VIZIO Performance Issues - New TV

Emsflyer84

Novice Member
Hey all, I recently picked up a 40" Vizio 1080p LED Smart TV from a big box store. It was a bargain TV for sure at under $300. But I can't help being super disappointed in the performance of the TV. We use it strictly for streaming in a child's room. The picture quality is fine, no complaints there. But the software is horrific. It is very slow to respond to button pushes on the remote. The lag is terrible. And sometimes, like this morning, I'll go to put on a streaming service like Hulu or Disney+ and I get a black screen with a spinning "loading" wheel on the screen and nothing ever comes on. It's been 10 minutes now and it's still spinning. Sometimes when this happens the TV doesn't accept input from the remote at all and I have to unplug the TV from the wall and "reset" it. I've gone in to check the wireless connection which the TV is telling me is excellent. And the same services are working on other TV's in the house.

Sometimes, after the TV has been on for a while, the audio will be severely lagging behind the picture, so everything is out of sync. I need to stop the streaming service, then go back in and restart the program to get it to sync up again. And then sometimes, when I go to turn the TV on, it just doesn't come on. The light on the front of the unit comes on but I just get a black screen, like it is freezing during boot up.

Now, I always thought VIZIO was a great value brand that made good products at good prices. This TV is convincing me to stay away and stick with the big electronics brands. I also had a 50" VIZIO last year that would not produce any audio when hooked to my cable company supplied cable boxes. No customer service on either side could help. That TV had to be returned for a Samsung. Is anything I mentioned here worth reaching out to customer service over? Or is this just the nature of buying a bargain TV? I hate to say it but my other TV's are older flatscreens (pre-smart TV) and I'm using ROKU devices and have far better performance and reliability this way. Thanks in advance all.
 
Last edited:

mikej

Well-known Member
I wouldn't waste your time with Vizio's customer service - if you've only had the TV a short time and it's displaying all these faults, then I doubt there's anything you can do about it. If a TV's audio is going out of sync with it's picture when using it's own tuner or apps and you don't have an external audio system connected, then that's shocking !

More often than not, you do get what you pay for. I would get your money back ASAP as the Vizio clearly isn't fit for purpose and buy something from a major brand like Samsung or LG.
 

Emsflyer84

Novice Member
I wouldn't waste your time with Vizio's customer service - if you've only had the TV a short time and it's displaying all these faults, then I doubt there's anything you can do about it. If a TV's audio is going out of sync with it's picture when using it's own tuner or apps and you don't have an external audio system connected, then that's shocking !

More often than not, you do get what you pay for. I would get your money back ASAP as the Vizio clearly isn't fit for purpose and buy something from a major brand like Samsung or LG.
I agree. And the audio issue IS just with the TV. There is nothing external hooked to it. I'm debating a quick sale and picking up something better. Thanks.
 

The latest video from AVForums

Samsung QN800B 8K TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom