Vista Media Center just won't play MKV files

Discussion in 'Home Entertainment Computers' started by jfk8680, Jan 29, 2009.

  1. jfk8680

    jfk8680
    Standard Member

    Joined:
    Jan 23, 2009
    Messages:
    3
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hi there,

    My Vista x64 Media Center just won't play MKV files. Windows Media Player plays the files just fine (according to GraphStudio all the needed codecs are in place). I've made the registry changes so the MKV extension is known to Windows and a double-click on a MKV file plays the file perfectly in Media Player.

    In Media Center however I keep getting the error message 'Cannot play video. Windows Media Center cannot open the file.' when I try to play it through either MyMovies or the default video's section.

    Any idea's???

    Thanks!
     
  2. paul_warren

    paul_warren
    Active Member

    Joined:
    Nov 23, 2006
    Messages:
    190
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +15
    Have you enabled the x64 version of media player??
     
  3. deksawyer

    deksawyer
    Active Member

    Joined:
    May 26, 2005
    Messages:
    1,641
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Fife, Scotland
    Ratings:
    +132
  4. Arteu

    Arteu
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Here's what I did to make it work:

    1) Install Vista 64 Codec Pack: |MG| Vista Codec x64 Components 1.7 Final

    2) Rename .mkv files to .m2v files

    For some reason Media Center would not open my files just b/c the .mkv extension, but changed them to .m2v and it worked.

    Cheers
     
  5. crazyal

    crazyal
    Active Member

    Joined:
    Feb 14, 2005
    Messages:
    521
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    Cov
    Ratings:
    +77
    Renaming files is not required.

    You need to tell windows what the perceived/content types are and you must also set the permissions for that type of file.

    The example below is for .mp4 file types, but it should work for others as well.

    Just change the mp4 text to mkv.

    Copy everything in red to Notepad and save as a .reg file and run it.

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.mp4]
    "PerceivedType"="video"
    "Content Type"="video/mp4"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Multimedia\WMPlayer\Extensions\.mp4]
    "Runtime"=dword:00000007
    "Permissions"=dword:0000000f
    "UserApprovedOwning"="yes"
     

Share This Page

Loading...