• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Virus Problem Help Needed

kd001

Established Member
Hi,

I use Microsoft Security Essentials as protection on my laptop. However, it was infected by a virus (a fake security software). I was able to remove the virus using Malwarebytes' Anti-Malware. However now I have a strange problem. When Windows (Vista) starts my desktop is completely blank. None of the icons and folders that used to be there are there anymore. Its just the toolbar and a blank desktop. All the software is still present but all the word documents, photos etc... seem to have gone. The weird thing is when I open a word document and go to 'recent documents' I am still able to access some of the missing files. But the folders in which they are supposed to be located are gone. I can't even find them using the search function. But it doesn't seem that the missing files and folders have actually been deleted. Because I have seen the anti-virus software scan them! They just seem to have been hidden. Does anyone know what might be going on here?

Luckily I keep a back-up of all the important stuff so its not a major problem but it still would be nice to get everything back to normal.

Thanks a lot,
KD
 

Member 513627

Established Member
Hi, try booting into safe mode. Once there run another Malware bytes scan.

Actually download something called ad aware and install that, before you scan with malware, then do them both at the same time, restarting after the first one finishes.

See if this brings back your icons, something is stopping windows from booting up normally and we have to find out what.

:)
 

Stiggy

Distinguished Member
Hi,

I use Microsoft Security Essentials as protection on my laptop. However, it was infected by a virus (a fake security software). I was able to remove the virus using Malwarebytes' Anti-Malware. However now I have a strange problem. When Windows (Vista) starts my desktop is completely blank. None of the icons and folders that used to be there are there anymore. Its just the toolbar and a blank desktop. All the software is still present but all the word documents, photos etc... seem to have gone. The weird thing is when I open a word document and go to 'recent documents' I am still able to access some of the missing files. But the folders in which they are supposed to be located are gone. I can't even find them using the search function. But it doesn't seem that the missing files and folders have actually been deleted. Because I have seen the anti-virus software scan them! They just seem to have been hidden. Does anyone know what might be going on here?

Luckily I keep a back-up of all the important stuff so its not a major problem but it still would be nice to get everything back to normal.
You need to identify which variant it was. Take a look at Bleeping Computer.

This malware marks files as hidden. With a bit of know-how you an unhide them. However, if a lot of damage has been done a clean install of Windows is recommended.

This is another example of MSE not catching malware before it does damage :mad:
 

kd001

Established Member
Thanks for the replies. In the end I solved the problem using a program called 'unhide'. It seems that the virus caused a fragmentation fault. But know everything seems fine.
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom