Virgin Media HDMI Splitter. Sound & Menu but no picture

Andy JB

Novice Member
Hi,

I am hoping someone can help please.

I am taking the HDMI out of my Virgin V6 box into the below HDMI splitter, and trying to extend into another room over cat6. I also need the 1080i signal to pass through the HDMI transmitter into the Sony TV in the same room as the V6 box, which was previously working. Now when I take the HDMI out of the transmitter into the Sony TV I get sound, the Virgin menu, but no tv picture. I get a picture when I switch to one of the apps i.e Netflix, but nothing from the satellite channels.

Is the splitter faulty or am I doing something wrong?

Amazon product

Regards,
Andy.
 

DavidT

Well-known Member
HDCP copy protection will stop this from working. If you need to watch TV in another room then you need a second STB.
 

JayCee

Distinguished Member
Hi,

I am hoping someone can help please.

I am taking the HDMI out of my Virgin V6 box into the below HDMI splitter, and trying to extend into another room over cat6. I also need the 1080i signal to pass through the HDMI transmitter into the Sony TV in the same room as the V6 box, which was previously working. Now when I take the HDMI out of the transmitter into the Sony TV I get sound, the Virgin menu, but no tv picture. I get a picture when I switch to one of the apps i.e Netflix, but nothing from the satellite channels.
The Virgin V6 is a Cable TV receiver not a satellite receiver.
 

The latest video from AVForums

Samsung S95B QD-OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom