Virgin 50Mb Problems in South London - Getting 20Mb speeds

hamzab

Standard Member
Hi guys,

Just had Virgin upgrade my Broadband to 50Mb today in Morden, at the start, as soon as the engineer went on the speedtest.net website (I must say he was reluctant to actually test the speed!) it read 30Mbps. Another few tests manage to raise it to 42Mbps but that was only once. Now, 4 hours after he has gone, it has never rose above 20-22Mbps.

So, after having countless problems with their 20Mb connections and getting around 10-12 with that, I decided to upgrade to the 50Mb "Flagship service", only now to discover I'm getting the download speeds I should have been getting last week but now paying a premium for!

When talking to Virgin on the phone the amount of excuses they come up with could fill a book, in the past 4 hours I've rang 4 times, twice they said it's my computer, the second rep said there was a problem on the line (this excuse was used 100 times when I first got virgin on 23rd September 2009) and the final one was I'll give you a call back, of which I'm now waiting.

Ping is also quite high, had this problem with 20Mb connection as well, when pinging forums for instance average is over 200ms.

Please help guys, been chucked around so much now it's actually bothering me now!

Thanks,

HamzaB.
 

markwww673

Well-known Member
Don't bother phoning. Just post to the VM support newsgroup. They are much better at sorting out problems. They will normally ask you to do a traceroute to bbc.co.uk & your power levels from your modem.

Mark..
 

The latest video from AVForums

Podcast: Q Acoustics Q3030i, Humax Aura, Roku Streambar & WandaVision Reviews and more...
Top Bottom