VERY URGENT HELP - Corrupted memory card(?) recover possible.

figoagogo

Distinguished Member
Hi

To cut a long story short my uncle visiting from Aus seems to have a corrupted card, meaning he has lost the last half of his photos from a trip to the UK (I backed up his first half, seem the 2nd lot were corrupted by someone else).

Any how - pls help me get them back, PLEASE... thing is I have little time, he is going back on Wed.

Here are the facts:

4gbm SDHC card, class 6
Fuji Fine Pix S5700 camera

The camera states "card not initialized"
Tried via Epson printer - card ports -Windows Vista states "You need to format the disk in drive K before you can use it"
Trie via USB adaptor - "do you want to scan and fix Removable Disc J" if I choose NO, I can get to the folders, but the do not show content, and they can of keep opening with them selves in a corrupt way.

I JUST NEED TO SAVE THE PHOTOS - and I know you guy no your stuff, and are alays there to help!!! Please :clap:
 

stevefish69

Well-known Member
I wonder if something like this may help

There are probably loads which are pulled up by googling "corrupted memory card retrieval"
 

Newton's Ring

Novice Member
I was going to link to the same kind of thing but you beat me to it.

Looks like it's a common issue with Fuji cameras. One guy suggested cleaning the contacts on the card - sounds like a longshot but maybe worth a try. Don't lose hope but trry and avoid the format option (although I've managed in the past to recover photos from a formatted drive).

Good luck.
 

burnzy

Novice Member
At work i've used Recover My Files found here: Data Recovery Software to Undelete Files; Disk recovery; Recover Deleted Files
I've used it on a few memory sticks that have either become corrupt or faulty. If that doesn't work theres a few other tools I use that I can't remember off the top of my head, will have a look at work tomorrow if you still can't recover your photos. Give that software a go, even if it just recovers some of your photos it's better than nothing!

Edit: Just noticed your camera and card, which we also have the exact same of (I work in a school) and I found the Card Initialisation problem is down to the camera for some strange reason not liking 4gb cards, re-formatting it to 2gb solved the problem. But guess that won't get your photos back for now. Good luck!
 
Last edited:

Desmo

Distinguished Member
Do you know anyone who's handy with linux? Photorec should do the job nicely.
 

figoagogo

Distinguished Member
Hi

I knew you guys would respond quickly and with good info - you have got to love the AVforums for the people that make it work so well!!!

As the time of posting I did google and I am using "recover my files", it is taking some time and counting a lot of files (more than the number of photos!).

I hope to get the data back.

Any suggestion for cleaning the contacts, white spirit, cotton buds? Or too strong.
 

Saldawop

Distinguished Member

PJTX100

Distinguished Member
Professional services also available on a no result / no fee basis but these can cost hundreds.
 

figoagogo

Distinguished Member
Recovermyfiles seems to have "recovered my files" at least it shows a preview, now I have to pay $59usd to recover them :rotfl:

As I don't want to pay, any freebies out there that WORK?
 

figoagogo

Distinguished Member
Hi

Done it - well its safe to say Recover My Files works!

Thanks to all who responded, thread can be closed now.
 

Solomon Grundy

Distinguished Member
Recovermyfiles seems to have "recovered my files" at least it shows a preview, now I have to pay $59usd to recover them :rotfl:

As I don't want to pay, any freebies out there that WORK?
Poor form, someone sits down and designs a service which works, is recommended and gets you out of a hole and you didn't want to pay for that service? Come on, in any case I'm glad you got it sorted...I'd hate that if I lost photo's of my kids and stuff so thanks for bringing recovermyfiles to my attention, just in case.
 

KhalJimbo

Distinguished Member
Glad you got it sorted
 

KoThreads

Well-known Member
Poor form, someone sits down and designs a service which works, is recommended and gets you out of a hole and you didn't want to pay for that service? Come on, in any case I'm glad you got it sorted. so thanks for bringing recovermyfiles to my attention, just in case.
Feel the same but glad to know a bit of software does work and the OP's pictures were saved.

I've paid for a couple of programs that said they had worked only for me to discover they didn't or did a bit. I won't buy anything now unless it's word of mouth or a full trial. Unfortuatley most people only need a 'get out of jail' fix once, and such a trial is all you need, so the writers are in a catch 22 situation.

If some precious photos were lost that would seem cheap to get them back.
 
Last edited:

Codehead

Distinguished Member
Are Fuji still using FAT12 for the memory cards? I had one ages ago, if you did anything with the card outside the camera other than read it, the data would be corrupted. :thumbsdow

I ended up modding my card reader to hardwire it read-only after Windows trashed two cards building a thumbnail db. :rolleyes: :thumbsdow

Glad the OP got his pics back though. :thumbsup:
 

figoagogo

Distinguished Member
Feel the same but glad to know a bit of software does work and the OP's pictures were saved.

I've paid for a couple of programs that said they had worked only for me to discover they didn't or did a bit. I won't buy anything now unless it's word of mouth or a full trial. Unfortuatley most people only need a 'get out of jail' fix once, and such a trial is all you need, so the writers are in a catch 22 situation.

If some precious photos were lost that would seem cheap to get them back.
I thought $60 was a bit steep, it wasn't my photos, so not my cost, but I reckon if they priced it more attractively then they could potentially get more sales.

I think a "get out of jail fix" is a fair one, and the price should reflect this, say $10 for one use/batch?

Any way the software worked (even recovering older files that were deleted weeks ago), so if any one has the same problem worth giving it a try.
 

IronGiant

Moderator
Did you still want this closed or left open for discussion?
 

figoagogo

Distinguished Member
I am happy for it to be closed - unless others want to discuss.

Thanks to all.
 

The latest video from AVForums

Podcast: Reported HDMI 2.1 bugs, Audiolab Amp & LG LED Projector reviews + Best of the Month
Top Bottom