Very happy 48’ C1 owner, not impressed with Sonos Beam 2

GE90

Active Member
Hi All

I’ve searched, but not really found a solution, so would appreciate your thoughts.

I purchased a C1 48” yesterday, with a Sonos Beam 2. After a little tweaking I’ve just about got the picture I’m looking for, but the sound with the Sonos is not at all good, to the extent that I had to check it was coming from the Sonos and not the TV speakers! I’ve come from a 6 year old Samsung with a Bose Solo.

Any tips or things to check?

I have it plugged into the Arc HDMI, and the various TV sound settings are in Auto.

The Sonos EQ is on default levels and Loudness is on. I’ve also done the True room set up, twice.

Any help much appreciated.
 

GE90

Active Member
Hi, thanks for your reply.

Well..... Coming from my old Bose Solo, it seems flat. Little depth - not very 'rich' if that makes sense? I've got used to it now to some extent, so perhaps somehow just a different set up, but not necessarily wrong? Absolutely no sign of any artificial surround sound (with the Bose sound seemed to travel across the room in certain situations).

It's probably normal (or something to do with settings), just different and hence to my ears (no professional!) it is disappointing!.

Thanks again.
 

reecie

Well-known Member
I have a original Beam and 48CX. The main difference is your Beam2 has eArc needed for the Atmos. Once you set sound output to HDMI on my tv you just have additional settings you can alter. I have my input HDMI set to bitstream and the DTV audio to auto. The Digital Sound Out to pass through so it just sends through whatever the device sends. I imagine yours will be much the same apart from enabling eArc. I also added a pait of Sonos One for surround sound and that does make a fair difference to the sound as the Beam is then not trying to do as much.
 

GE90

Active Member
Thanks. I’ve changed Digital Sound Output from Auto to Pass Through. Not certain whether this will change much in practice!?

Many thanks
 

SSThing

Active Member
Settings/all settings /sound/additional settings /HDMI input audio format.
Try toggling between PCM and Bitstream.
 

SSThing

Active Member
Thanks very much. However, I only seem to have PCM, Auto and Pass Through.
That's in "digital sound out", the wrong section.
If "HDMI input audio format" is greyed out, it's a bit of a faff to access it but firstly disable EARC, swap the TV to the port that the Sonos is plugged into, then use the steps above and the hiaf options should be available. But, after toggling between PCM and Bitstream, remember to reactivate eARC.
 

The latest video from AVForums

Podcast: Panasonic JZ2000 Final Thoughts - TV Calibration: Should you? And More...
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom