Using Shellys 2.5s locally only (i.e. non-cloud)

johnieutah

Active Member
I am new to Shelly and home automation in general.

I've recently purchased some Shelly 2.5s to control my window blinds. Installed one and everything works fine. However, I can't work out how to use them locally only and still make use of the Shelly app.

Maybe I have misunderstood something here, but in all of the documentation and instructions, it does state that they can be used locally by simply deactivating the cloud option. However then I am unable to use the app - "device offline" it states - and then only the web-interface through the IP address works. I need this to be wife friendly, and I want to install a load of them, so access through the app is key.

Does anyone have a definitive answer here?
 

johnieutah

Active Member
Thanks for the reply.

So you disabled cloud access from within the device settings page in the app? - when I do this I then just get device offline, and then I basically can't do anything. I am on the same network for sure... can access it directly through its IP address. Maybe something to do 2.4ghz/5Ghz from my Ubiquiti gear...

Cheers.
 

Seb Briggs

Well-known Member
Yes, disabled in the app

You are probably right with the Ubiquiti issue, as just tested with my phone connected to my upstairs 2.4/5Ghz AP, whereas the module is downstairs connected to a 2.4Ghz only AP.

When i tested it earlier i was connected to the 2.4Ghz AP
 

Seb Briggs

Well-known Member
You would have to create a separate 2.4Ghz SSID for Shelly and make sure your phone(s) connect to this, or use cloud access
 

Fabien

Active Member
Try setting static IP address on Shelly but with no gateway details. Outside of dhcp range bit within the same private subnetting

Fabien
 

johnieutah

Active Member
Thanks for the replies. I will play around with it this weekend.

Just need to make everything works as expected before I go ahead and install the other 7.

One other question. I use iOS, the wife Android. I wanted to flash the Homekit firmware as I like the OS integration Apple provides. Will doing does this still allow the app on Android to see and control the device?
 

johnieutah

Active Member
I installed another Shelly 2.5 and it's got the same issues with connectivity. Eventually I just reset everything and connected them to the cloud and that seems to work consistently at least.
To test further, I have disabled cloud and it does indeed work... sometimes. So @Seb Briggs Thanks for the tips. However it is very flaky and has low WAF. If I flash the homekit rom then everything works great, but then the wife can't control the blinds on her Android phone. Hmm.

Anyways, after further playing around, it seems that whenever a device is "offline", I just start the app new and there it is working fine again. So maybe it's just the app that is crap? I don't really want to have to go the hassle of having separate 2.4ghz SSIDs, but I guess if I have to I would. Apparently there is a new app in the works so maybe this will sort those issues out. I guess another workaround I could enable cloud connections but block the ports in the USG? I just don't like the idea of putting the controls outside of my local network.
 

johnieutah

Active Member
Try setting static IP address on Shelly but with no gateway details. Outside of dhcp range bit within the same private subnetting

Fabien
Ok I will give this a go too. I only set static IPs for the Shellys from with in the Unifi controller, I guess it doesn't make any difference if I do it there or directly within each device?
 

The latest video from AVForums

Oculus Quest 2 VR headset + Rotel A14 MkII Amp Reviews & Best of the Month
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom