USB's not working

Discussion in 'Desktop & Laptop Computers Forum' started by keztricks, Feb 3, 2009.

  1. keztricks

    keztricks
    Standard Member

    Joined:
    Jul 1, 2008
    Messages:
    4
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    4 of my 6 usbs have stoped working, ive re installed drivers and checked dvice manager and it claims they are working properly my 2 front usbs and 2 of the 4 on the back are affected anybody know whats wrong or how to fix it

    thanks

    ---------------- Now playing: The Beatles - Lucy in the Sky With Diamonds via FoxyTunes
     
  2. rd5

    rd5
    Standard Member

    Joined:
    Feb 3, 2009
    Messages:
    1
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I had a similar problem a while back. The ports disappeared of the radar and Windows wouldn't recognise memory sticks. I did a little Googling and turned up a solution.

    After you power down, make sure the unit is then switched off at the mains, and wait for about 30 seconds. Apparently, this allows some capacitors inside the main unit to discharge fully, and then the USB ports all become operational again.

    No doubt someone with more technical knowledge than me will explain why this should be the case, but the fix certainly worked for me, and also a second time recently when the problem recurred after the machine had been running for about 18 hours.

    Hope it works for you, too.
     
  3. EarthRod

    EarthRod
    Distinguished Member

    Joined:
    Jul 15, 2008
    Messages:
    17,780
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Location:
    England
    Ratings:
    +7,881
    Hi

    Go to Control Panel > System > Hardware > Device Manager. Click on "Universal Serial Bus Controllers" which will list the USB ports.

    The ones not working should have a red cross on them. Delete these and restart your computer. That should respawn the USB port drivers and correct the problem.

    If no red crosses delete them anyway and let the restart correct the problem.

    Let us know how you get on.

    Alan
     

Share This Page

Loading...