USB problems....... i think?

Discussion in 'Computer Components' started by reevesy, Jul 4, 2015.

  1. reevesy

    reevesy
    Distinguished Member

    Joined:
    Feb 20, 2005
    Messages:
    6,338
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +2,191
    hi all....
    just recently ive been having problems with my permanent conected usb stuff...ie mouse ...wireless keyboard and a little usb connected sound stick thingy...most regular problem is with the mouse and the sound device.

    for example the mouse is fine for a bit...then will freeze...or move about but left or right clicking wont work...or it will randomly bring up right click stuff like high lighting text etc .

    when this happens if I Ctrl/alt/Delete and select task manager (just bringing the window up with things that are running...I don't have to select or do anything else )...it nearly always starts working again.

    the keyboard will on the odd occasion will stop working so I have to disconnect the usb cable...and re-fit it.....windows will then bring up installing driver for device...starts then says it couldn't install..(assuming its already installed)...then it works ok....same thing for the usb plugged in sound card thing.
    bought a new mouse...still had the same problem....though it might be Kapasky anti virus...so uninstalled that ...but still same problem......have also tried different usb ports

    ...took the pc apart and inspected the usb ports...had a clean around while I was at it

    I'm using a hp prolient sever pc thing with win 7.

    I don't know if it is a software or hardware problem...I'm guessing the usb port side of things but ..


    Edit :....mouse seems to be playing up more and more....plus I've notice that I don't have to select anything when bringing up Ctrl/Alt/delete....just bring the window selection up...and cancel it and the mouse works fine for a bit

    1....I don't know if this is the case....was going to see if it still happens after the win 10 update

    2....how to confirm its the usbs or test to see if this is the case

    ...if is the case i'll have to try and order a replacement part from hp...don't know the best place for that would be.

    bit of a pc luddite so any help/guidance would be most appreciated

    cheers
     
    Last edited: Jul 6, 2015
  2. reevesy

    reevesy
    Distinguished Member

    Joined:
    Feb 20, 2005
    Messages:
    6,338
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +2,191
    Anyone ?......

    Driving me potty
     
  3. reevesy

    reevesy
    Distinguished Member

    Joined:
    Feb 20, 2005
    Messages:
    6,338
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +2,191
    don't think I'm going to get any joy here...probably better in another section

    Mods...could this post be moved to the software section please

    cheers
     
    Last edited: Jul 6, 2015
  4. Dbcoup

    Dbcoup
    Well-known Member

    Joined:
    Jun 25, 2007
    Messages:
    4,380
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Here,There,Everywhere
    Ratings:
    +880
    Do you still have access to the mobo drivers? If so, uninstall the drivers and reinstall. Sounds like a corrupt driver or some other file is conflicting.
     
  5. reevesy

    reevesy
    Distinguished Member

    Joined:
    Feb 20, 2005
    Messages:
    6,338
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +2,191
    Did go through all USB drivers and checked to update... Wasn't sure if it was a good idea to Un install..

    There is a single internal USB socket separate from the others on the motherboard.. Tried the mouse sender in that....

    Same thing is happening

    Now wondering if it's software
     
  6. Dbcoup

    Dbcoup
    Well-known Member

    Joined:
    Jun 25, 2007
    Messages:
    4,380
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Here,There,Everywhere
    Ratings:
    +880
    Difficult with limited info but have you recently installed anything? Can you remember when this started?
     
  7. reevesy

    reevesy
    Distinguished Member

    Joined:
    Feb 20, 2005
    Messages:
    6,338
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +2,191
    yeah been 2 or 3 weeks now

    ....I thought it might have been Kaspersky anti virus...but I uninstalled that and used microsoft security essentials for a bit but still had it.

    ...the only other programs I download recently were 2 other back up manager type things ...I've just uninstalled one...need the other for now.

    the only other thing in my program list is a recent security update for adobe flash player ..adobe activeX

    cheers
     
  8. Dbcoup

    Dbcoup
    Well-known Member

    Joined:
    Jun 25, 2007
    Messages:
    4,380
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Here,There,Everywhere
    Ratings:
    +880
    Have you tried removing and uninstalling the usb sound device and its drivers?
     
  9. reevesy

    reevesy
    Distinguished Member

    Joined:
    Feb 20, 2005
    Messages:
    6,338
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +2,191
    ...well it has detected itself and re-installed itself a few times..
    the mouse is the thing that's driving me potty.

    tried re-installing usb drivers....but so far that hasn't worked

    trouble with that is when you do the host controllers in device manager for example....and theres a few on the list...3 I think....you uninstall one...lose your mouse so have to reboot...so the diver can install and you can use the mouse again.

    ...then go back to the controller list...and theres 3 there again...so you then select the next one on the list....but how do you know if windows has put the last one back to the top of the list again...so you uninstalling the one you've just done!?

    probably a stupid question...but I couldn't see anyway of id-ing each one?

    :confused:
     
  10. Dbcoup

    Dbcoup
    Well-known Member

    Joined:
    Jun 25, 2007
    Messages:
    4,380
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Here,There,Everywhere
    Ratings:
    +880
    The USB sound device could be causing the mouse to play up. Just because its acting weird doesn't mean its at fault. If the device keeps trying to reinstall there was an error on the first install.
    Totally remove everything to do with the sound device and reboot. If it is still the same then at least we have eliminated one avenue.
     
  11. reevesy

    reevesy
    Distinguished Member

    Joined:
    Feb 20, 2005
    Messages:
    6,338
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +2,191
    well......tried win 10....that didn't work...plus after a few problems I went back and did a clean install of win 7

    ...still got the problem of the mouse......every few times it moves around but wont do anything.
    ....a quick ctrl/alt/delete followed by a cancel and everything works fine again?
     
  12. reevesy

    reevesy
    Distinguished Member

    Joined:
    Feb 20, 2005
    Messages:
    6,338
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +2,191
    Well.... Got a new pc...... New win 7 64 bit operating system

    ....... Still got the same problem!
    Can only think it's a problem with logitech wireless mice and win 7.

    No new drivers about and a Google has brought up a few problems and potential solutions..... But not the problem I've got?

    Short of buying yet another mouse from a different company I'm stumped
     

Share This Page

Loading...